Factory reset and update doesn't work

To fix ongoing problems with packages I decided to do a Factory reset #2 to stock software. Everything went great until the wizard started updating the device. The device reported failed update with X on the screen and proceeded to the next screen. This results in a timeout. I tried this three times with the same result each time. Then I disabled automatic updates and proceeded to run with stock software.

I’m surprised the device can’t be reset and updated. The updates are the main feature, why is it broken?

Also, this is the log from “Software” update package lists command.

Downloading https://api.turris.cz/openwrt-repo/omnia/packages//base/Packages.gz. Downloading https://api.turris.cz/openwrt-repo/omnia/packages//base/Packages.sig. Signature check failed. Remove wrong Signature file.

Full log: https://pastebin.com/2vWGqSty

You guys apparently decided to change the SSL certificates and this broke the entire Turris OS the device shipped with.

Is there a permanent fix for this? Re-flashing with new base package?

The right path is https://repo.turris.cz/omnia/packages/base/Packages.gz

The right path doesn’t matter - this is the path stock Turris OS on Omnia is downloading packages from.

i too am having the same issue, i dusted off my turris omnia and reinstalled in my home, i did a factory reset (reset button, 3 lights, flash back to factory settings) . when it tried to update itself in the beginning setup wizard it wasn’t able to update and marked an x on the screen saying it failed, which hindered me from further using the device so i had to do another factory reset just to bypass auto updates so it would work off the reset. what is going on here? i need help since all my firmware is back to factory and nothing is updated (security, qos, wifi problems)
i also have an issue where wifi goes out after a reboot, causing me to have to reboot the device a second time in order for it to come back on. (pulls hair out)

The initial wizard is broken. If you disable updates first, configure the router and then re-enable updates later it starts working as expected. The software image Omnia shipped with is currently broken this way after they apparently changed DNS and SSL certificates.

ok i did this, and now the kernel sais 3.6.1 version number. is this correct for the latest firmware? and if this is how did it not ask for a reboot when it installed it, it didn’t say anything after i enabled auto updates later when setting it up, just curious on that front as to how it downloaded the update in the background , thought it would take a long time

My current version is:

Turris OS version 3.6.1 Kernel version 4.4.51-627f0117679bc72ef5e58881035f567a-3

Looks OK to me.