External Hard Drive NOT Showing Up

It is connected via USB. Why can I not access it?

Thank you


Do you have configured SAMBA ?
You must setup samba share.

SAMBA has not been configured; I will get right on it.

Thank you!

Before configuring SAMBA, try a


The usb-hard disk not showing is one thing that might like Stybyk said be because you have not configured SAMBA yet. But it must be already visible in the lsub output. Post the output of it, if you can.

If it is visible in the list, then no worries.

This is my output. How do I access the drive?

root@turris:~# lsusb
Bus 005 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0bc2:3008 Seagate RSS LLC 
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

if you run command “dmesg” you should see sdX device shown in the log when your Seagate is detected. You can use special /dev/sdX and /dev/sdXN files as block devices. X is a letter and N is a partition number if the disk has been partitioned. If there is no file system you can create it with mkfs* cmmands or you can mount it with mount command, for example mount -t vfat /dev/sdXN /mnt/mydisk after you have created /mnt/mydisk directory with mkdir.

Does the Turris Omnia come with lsblk ? I find that quite good for listing block devices.

A few questions

  1. Are you a windows user or a Linux user?
  2. How big is the drive?
  3. Do you have any partitions on it?
  4. You want to access your drive through network right?
  5. type “lsblk” like @Paul_Totterman said and copy and past the output in one of the posts.

Yes, there is lsblk.

I’ve run into the same problem with a 2TB Seagate Backup Plus, only in my case the drive does not show up when running lsusb, fdisk or lsblk. On the other hand, I have no problem accessing a smaller sized USB drive (32GB Kingston DT). Any tip on how to solve the problem?

If it doesn’t show, probably it is because it doesn’t have enough power. You said the USB drive does show, so i think this has to do with not having enough power.

Many times those drives have external adapter to provide extra power to spin the drives.

What also could be if you do have connected the external power adapter, maybe for it you need to install some drivers first. Sometimes those external hard drives with extra functionality need those drivers.

The drive comes with its own power adapter and it is formatted to ext3 fs, which is supported by openwrt. I used it on a router running asuswrt merlin.

If that is the case, then we for sure can conclude it is not a openwrt-problem.

It leaves to things out.

  • Bug

  • Turris Omnia (hardware problem/issue)

Try the following options.

  • Try another USB-port. If it still does not work, try connecting to your own computer, so we for sure can conclude that is not the external case or the usb-cable at fault

  • Can you turn off the Omnia, then connect the external drive to it, then start the Omnia. After that, could you post the system log.

I tried both USB ports and got the same result. I can access all the files on the external drive from my computer, on all ports (USB 2.0 and 3.0), so the cable does not seem to be at fault.

However, upon rebooting Turris with the drive plugged in the system log does show some issues:

2016-11-22T21:36:14+02:00 err kernel[]: [  355.277558] usb usb5-port1: Cannot enable. Maybe the USB cable is bad?
2016-11-22T21:36:15+02:00 err kernel[]: [  356.487524] usb usb5-port1: Cannot enable. Maybe the USB cable is bad?
2016-11-22T21:36:17+02:00 err kernel[]: [  357.697498] usb usb5-port1: Cannot enable. Maybe the USB cable is bad?
2016-11-22T21:36:18+02:00 err kernel[]: [  358.907457] usb usb5-port1: Cannot enable. Maybe the USB cable is bad?
2016-11-22T21:36:18+02:00 warning kernel[]: [  358.936058] usb usb5-port1: config error

It tries to connect the drive during the entire boot, until it finally gives up. I am at a loss.

At loss? I see this as good progress. I mean we HAVE SOME INFORMATION…where to look for :grin:

I found this https://ubuntuforums.org/showthread.php?t=1195601

This problem apparently occurs many times. I will be google-ing for more.

Edit2: https://www.raspberrypi.org/forums/viewtopic.php?t=62225&p=462172

Edit 3: I decided to search on the web to find the information about your “2TB Seagate Backup Plus”. The adapter is just a USB-powered adapter. Not a separate adapter. I though it was a separate adapter. Oke, if it is possible, try to put a USB-HUB between it. To see if the USB-HUB can give you a temporary solution for the time being.

Actually I use a Seagate Backup Plus Desktop Drive (https://youtu.be/z3xSyHI5Trs?t=48s, mine is the 2TB model), which comes with separate AC adapter. It’s the slim/portable one that is USB-powered.
I’ll keep looking for a solution, but for now I think Turris is at fault.

Well could you still try the solution of a USB-HUB between the Turris and the Seagate drive? If that might give a “go”?

I also recommend testing with powered USB hub.

@white, how would a USB hub, powered or not, change anything? Is the signal modified in any way?

To make the answer simplified.

USB has of its own also certain amount of voltage that it delivers. Maybe it isn’t delivering enough power to make the connection work with you drive. By having a USB-hub especially a powered USB-HUB you can have sort out two things

  • To be certain that it is getting the enough voltage

  • Have a sort of “man in the middle” kind of idea. If somebody does not want to talk to you directly, then have a person that intercedes on behave of him with you. So the USB-HUB is doing that. Or well that is how i see it, maybe @white sees it differently or knows something that i do not.