Excellent article on DSA and VLANs in OpenWrt forum

I was reading my weekly update from the OpenWRT forum and saw this article on VLANs with DSA on OpenWRT and it looked very clear and comprehensive.

2 Likes

Unfortunately, it is not present in OpenWrt 19.07, and it is questionable if they will include it also in OpenWrt 21.02. I hope that they will do. :pray:

Right now, it is included only in OpenWrt snapshots. :eyes:

1 Like

I also saw this helpful article in my weekly summary.

I think it is very good that you are referencing to this post here for future use. Thank you!

1 Like

@Pepe Do you mean the LuCi support, or DSA in general? I thought DSA had been available (although not for all drivers) for a while now. In fact, my TO seems to be using it.

I ask because you responded to a tutorial that includes both LuCi setup and the equivalent in config files. I’m assuming the config would work just fine, is that correct?

I mean the LuCI support for Bridge VLAN filtering and so on, but OpenWrt included it in OpenWrt 21.02 RC2, so it is already in the HBD branch, but it requires some changes in reForis to make it compatible.

Excellent! I’m using LuCI and config files directly for my VLAN config so I don’t mind it missing from reForis.

I’m going to take it for a spin.

Will all Turris routers support DSA implementation?
It is still unclear to me what are the exact benefits of DSA over swconfig, except that DSA is “officially” in the linux kernel whereas swconfig was not. People are debating on the OpenWRT forum but I must admit it’s a bit beyond my knowledge.

Since Turris OS 4.0, all Turris routers are already using DSA, so you don’t need to worry about it. They just make it easier to configure L2, L3 in LuCI, including VLAN tagging and so on for them and for us, of course.

Many people who have the upstream/vanilla OpenWrt version will complain regarding version 21.02 that they need to configure the router from scratch as it won’t migrate network configuration during sysupgrade while switching from swconfig to DSA.

2 Likes

I’m trying out this setup on my TO, running TurrisOS 5.2.1.

I currently have lan2 unused, so I’m trying to use it here in order to not interfere with the current setup.

I’ve added this to /etc/config/network:

config device
	option name 'br-test'
	option type 'bridge'
	list ports 'lan2'

config bridge-vlan
	option device 'br-test'
	option vlan '59'
	list ports 'lan2:t'

config interface 'test'
	option device 'br-test.59'
	option proto 'static'
	option ipaddr '192.168.59.1'
	option netmask '255.255.255.0'

But after a reboot I still don’t have the test, br-test or br-test.59 interfaces:

turris# ip a | grep test
turris# ip a | grep '\.59'
turris#

The TEST interface is present in LuCI but shows Error: Network device is not present.

Does anyone know what I’m doing wrong?

I think this only works on OpenWrt 21.02 (currently available in HBD-branch for Turris Omnia as @Pepe stated).

1 Like

I thought that was only the case for the LuCI support.

Actually it is the case for UCI-support - the webinterface LUCI is just a frontend for UCI-parameters, touching configuration (like /etc/config/network) via ssh is another one.
Right now you can only configure DSA directly via ip/bridge commands.

1 Like

I understand the distinction between the different configuration methods. I thought it was only the LuCI support that was missing because that was literally what @Pepe said in response to my previous question:

In any case, thanks for the clarification. I tried updating to HBD but it bricked the router and I had to factory reset in order to restore the snapshot prior to the upgrade so I’ll wait a bit longer.