Ethtool issues with eth2

Hi,

I am trying to connect a TO (6.5.2, firmware not yet updated; eth2-switch set to SFP) via fibre to fibre switch (TP-Link SX3008F). The switch does not allow autoneg (no idea why - only fixed 1000M or 10G; I will contact their support tomorrow), I therefore set the switch to speed 1000/full duplex. When plugging in the DAC-cable, I get no connectivity.

root@turris:~# ethtool eth2
Settings for eth2:
        Supported ports: [ ]
        Supported link modes:   2500baseX/Full
                                1000baseX/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  2500baseX/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 2500Mb/s
        Duplex: Full
        Port: Direct Attach Copper
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: d
        Wake-on: d
        Link detected: no

Syslog:
Feb 22 21:49:00 turris kernel: [15889.570350] sfp sfp: module FS               SFPP-PC01        rev A    sn G2330438860-1    dc 231010  
Feb 22 21:49:00 turris kernel: [15889.579710] mvneta f1034000.ethernet eth2: switched to inband/2500base-x link mode

With the switch in 1000M and the TO in 2500M-mode and autoneg not working it is clear why it does not work.
I therefore tried to change the speed manually, but get the following error:

root@turris:~# ethtool -s eth2 speed 1000
Cannot advertise speed 1000

I tried other modules but it seems I can not set speed at all (autoneg off and duplex half neither work). The only module, that does work, is the Turris SFP (with speed 2500 obviously).
Do others have this problem as well? What to do here to bring up the link between switch and TO?

Best,
ssdnvv

Ok, then this seems to be a bug. I will file an issue at gitlab.

Possibly related to This?

No, I doubt that it is related - I can set speeds on other modules, but not on this one (even though it reports to support link rate 1000.
Created gitlab-issue: Ethtool - cannot connect DAC cable in 1000baseX-mode (#950) · Issues · Turris / Turris OS / Turris OS packages · GitLab

1 Like