Error: Signature validation failed


#1

Hye since last we, I have this error:

> ##### Error notifications #####
> Updater selhal:
> 
> corruption: Signature validation failed

Any ideas?


#2

#3

This one seems different to me.


#4

Would you please login into Foris and go to Updater tab and click on Save changes, if the error shows up again?

Did you get the notification just once in Foris? Updater checks every 4 hours if there is a new update. So, if you get it multiple times, then it’s something wrong.


#5

I get it regularly (maybe every 4hours). See attached screenshot:


and there is more to count, 31 notification email.

Thanks for you reply.


#6

OK, Would you please follow our article for Error reporting, which is in our documentation? So, we’d be able to check from diagnostics, why the signature validation failed. Also, we need from you all keys, which you can find in /etc/updater/keys.

Please send it to tech.support@turris.cz and don’t upload diagnostics to any public file hosting or cloud as they contain sensitive data.


#7

It will take a little bi tlonger than expected, tonight when trying to acces luci, it was unreachable. So I tried rebooting the router. Loop in reboot. So I tried a last snapshot reboot (the 2 leds) and nothing, it’s still in loop reboot. So I have to flash it.


#8

I think my router is dead, can’t even flash it or reset it to default firmware…