Error reForis - not valid JSON

Vcera som si upgradoval Turris Omnia (silver) na poslednu stable verziu. Ked sa chcem prihlasit, vidim iba sedu stranku s textom:

Unexpected token ‘<’, “<?xml vers”… is not valid JSON

Ked restartujem router, tak na niekolko chvil sa viem prihlasit, ale potom zase ukaze tento error. Moze mi prosim niekto poradit?

Z jaké verze jsi vycházel (3, 4, 5, 6 ? ) ? Přeskočil si nějakou větev ? Nebude lepší čistá instalace?

Neviem ci som preskocil nejaku ciastocnu verziu, ako vzdy, videl som upozornenie, ze je nejaky update, tak som odsuhlasil, uz dost dlho som na v6, takze ziadny velky upgrade. Zaujimave je, ze ten error sa ukazuje iba niekedy, cez SSH sa do turrisu dostanem, a vsetko sa zda byt funkcne inac, zda sa to byt error but httpd alebo reForisu. Cista instalacia neprichadza do uvahy, pretoze som niekolko tisic km daleko…

Podle hledaní na webu … nějaká chyby syntaxe či poškozený soubor. Podívat se do syslogu, preventivně vyexportovat analytiky a na chvíli si je odložit.

Mechanické řešení je vrátit se pomocí schnapps v reForis na starší verzi, kde problém nebyl a nechat běžet aktualizace znova.

Snad se ozvou i chytřejší než jsem já :slight_smile:

Hi, i have the exact same problem.

JSON.parse: unexpected character at line 1 column 1 of the JSON data

it started out of the blue. I dont know what exact changed at the time.

I am on turris-os 6.2.3

The funny part for me is i have 2 of these devices and only one shows that error. The other one works fine.

root@turris-2:~# cat /etc/os-release
ID_LIKE=“lede openwrt”
PRETTY_NAME=“TurrisOS 6.3.2”
BUG_URL=“Issues · Turris · GitLab
SUPPORT_URL=“Turris - Podpora
OPENWRT_RELEASE=“TurrisOS 6.3.2 f8282da11ee77c36acb1bd94c99b76ce13257ab9”



sorry i mistyped. I am on turris-os 6.3.2


i was able to recover mine with the command line utility schnapps to manage snapshots

schnapps list
schnapps rollback
run the updates again from the web interface



Hi, unfortunately I have the same problem as described here and do not know how to get ahead :cry:

Login via SSH works fine, but I cant get to the web interface > JSON.parse: unexpected character at line 1 column 1 of the JSON data

I have flashed to the latest version via medkit, but that did not help either.

root@turris:~# cat /etc/os-release 
ID_LIKE="lede openwrt"
PRETTY_NAME="TurrisOS 6.3.2"
OPENWRT_RELEASE="TurrisOS 6.3.2 f8282da11ee77c36acb1bd94c99b76ce13257ab9"

Try restarting the device and logging in as soon as possible. I was able to log in that way…

1 Like

Yes, that just worked for me too, but surely that cant be the solution forever?

My suspicion is that there is some issue with a JSON that builds up only after a certain time from reboot … hope this will be fixed soon, really annoying

Same problem here “JSON.parse: unexpected character at line 1 column 1 of the JSON data” when going to and “503 Service unavailable” when going to reforis/login.

Ha the same here, did multiple schnapps to roll back to n/a, after update to 6.3.3 from 6.3.2 it will not let me in. only via SSH and then it updates itself again and the circle continues…

Takze, kdyz se na to podivam z jakehokoliv uhlu, vypada to na fatory reset. Cloveka prestane bavit nekonecne nocni resety.

Nekdo zkusil totalni reset a med kitu…?

Zdravim a doufam, ze nekomu se zadari najit “jak na to”… M.

hi, same issue here on 6.3.3.
omnia turris is working fine (network, wifi etc)
ssh is good too
i can access the luci web interface but
is showing an unhandled exception :

root@turris:~# cat /var/log/lighttpd/error.log
2023-07-02 13:52:43: (…/src/server.c.1588) server started (lighttpd/1.4.67)
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr:Traceback (most recent call last):
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/site-packages/flup/server/”, line 576, in run
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/site-packages/flup/server/”, line 1175, in handler
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/site-packages/turris_auth/server/”, line 83, in _main
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/site-packages/turris_auth/”, line 116, in verify
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/http/”, line 483, in init
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/http/”, line 532, in load
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/http/”, line 596, in __parse_string
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/http/”, line 488, in __set
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr: File “/usr/lib/python3.9/http/”, line 353, in set
2023-07-02 13:59:35: (…/src/mod_fastcgi.c.450) FastCGI-stderr:http.cookies.CookieError: Illegal key ‘sah/contextId’

removing the cookies related in firefox did the trick.

1 Like

It is annoying for sure, what I did was another way, maybe faster if you define a proper shell alias directly to be run from your computer to the router over SSH.

The steps without aliasing are universal:

  1. SSH to your Turris router;
  2. Run: /etc/init.d/lighttpd restart

Now I am able to web-access the router. Works for me.


The same problem occurs with me occasionally, a reboot helps, but a solution is still missing.

An issue was opened in Turris gitlab: turris auth breaks lightppd (#929) · Issues · Turris / Turris OS / Turris OS packages · GitLab

@Thomas_Lagane thanks for providing the details.

1 Like

A problem for me today as well

  • 1 for me, did rollback, right after update the same error… /etc/init.d/lighttpd restart works.

today the error are and not working default page … removed by recommended reset of lighttpd