Error opening journal: No space left on device

Occasionally, I will receive this error message after an update is applied:

Updater failed: [string “transaction”]:351: Error opening journal: No space left on device

In some cases, this is because I’ve created schnapps snapshots. Is there a way to configure schnapps to only use X amount of space?

Is there another cause of this message? Shouldn’t the device manage /tmp space automatically?

have you tried df to see just what’s out of space? do you have any overly large log files taking up space on / (assuming it’s / out of space). it’s my understanding that schanpps uses btrfs’ snapshot ability so it’s not actually making clones of the disk, just deltas as you go along (someone correct me if i’m wrong). have you ever cleaned up any old snaps? schnapps list and schnapps delete ### will clean up old snapshots.

For completeness, /tmp is in RAM, and filling that isn’t good (typically even DNS won’t get served).

Craibuc - it looks like the culprit is /dev/mmcblk0p1

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mmcblk0p1 7633920 7629704 0 100% /
tmpfs 1035372 8692 1026680 1% /tmp
tmpfs 512 0 512 0% /dev
/dev/md0 3906887360 115024616 3790112984 3% /mnt/raid

Looks like I had the same problem: [SOLVED] 100% usage on /dev/mmcblk0p1 - #10 by craibuc - Turris Omnia - Turris forum