Error 500 or 503 accessing Foris - MOX

Hi Iam receiving 503 Service Not Available or 500 Internal Server Error when trying access Foris on my MOX device. Restarting router dont help. LuCi working fine. Thank you

1 Like


May I ask you if you have installed package python3-python? If you don’t have it installed, please install it and Foris should work after reboot of your router.

In some cases, which we are investigating, update didn’t finish and if you will run pkgupdate from your CLI or do a reboot of your router, it will detect previous run of update and it will try to finish it.

1 Like

@Pepe thanks for the info.

I had the same problem. Installing python3-python did not work for me because of package conflicts, but running pkgupdate from CLI via ssh solved this issue for me.

The same problem… Luci working, Forris ending with error.
When try run install “python3-python” take this:

Installing python3-python (1.0.0-1.0) to root…

Collected errors:

  • check_conflicts_for: The following packages conflict with python3-python:
  • check_conflicts_for: python-base *
  • opkg_install_cmd: Cannot install package python3-python.

But run pkgupdate from ssh resolve problem for me.

my issue was fixed automatically through the night. My IPv6 was disabled. it seems that it is bug in distribution of the update.

Interesting, what others?

Got this yesterday setting up my new Omnia Turris 2020, Luci is all good, but Foris died during install and if I didn’t care about the whole system working I’d leave the little bugger dead. I’ll try the Python3 install.

Python3 was already installed.

Forum is not bug tracker, forum is just driven by community. If you would like to get help, there is an article in our documentation for Getting help. If you know that there is a Python3, which is by default preinstalled, you can provide some logs, am I right?

What means Foris died? Honestly, I don’t know. 500/503?

No worries. I’ll pull data and send in a big report in about a month when I’m back onsite. Have a better one.

But you had time to post it here and said little bugger dead and then you are going to say that you will send us diagnostics after one month? I am not sure if I understand what you wanted to say.

//EDIT: I see that you are newly registered and these three posts are only your posts on this forum.

I don’t think anyone is worried here.

Had the same issue, as a bonus both wifi adapters on MOX were “working” on SW side, but not actually providing any wifi (SSID was not broadcast).

pkgupdate is the way to go, some 50 packages were still not updated (among them python3)

BTW: Since pkgupdate knows it’s in the middle of unfinished upgrade, maybe it’d be wise to detect this on reboot and resume?

I have had the same situation - no WiFi and no Foris. Running pkgupdate from command line helped to resolve this situation - package installation finished and all post-processing finished and now the router is working again. :sweat_smile:

I had the same - the update happened to me during a conference call so I was pretty pissed. The hardest part was to figure out what happened. I was thinking my MOX is dead for a while. I am no that skilled in Linux so it took me couple of hours to make it work again. The problem was that the update was somehow stuck in the middle.Errorlog was missing which didn’t help at all. Finally, I got the idea to run pkgupdate (which I was not familiar with before) and after that everything worked again. Really unpleasant experience…

Got the same on my Mox, the Omnia updated all correctly. Luci said python3-python was installed, just not linked…
Perhabs this fix should be posted somewhere more prominently…

I did a full internet restore to resolve. After I found that info. Really shouldn’t be an issue for a new device out of the box. Nice to see I caused a stir early on.