ERR_CONNECTION_REFUSED after updating to Turris OS version 3.3

I’m unable to access the router’s web admin portal after updating to version 3.3. It appears the router is refusing my remote connection attempts.

Me too. What is this.

It might be that the upgrade partially failed and HTTP server doesn’t work due this. If you have enabled SSH you can try that to fix the issue. Otherwise you could try a rollback to the latest snapshot to remove the update:

if you are re-flashing the image, medkit, seems to have some problems:

It seems I do have access via SSH. Can you share some exact steps I should take to fix the HTTP server issue?

I run and fix the problem. But now I get in the Home Page

Updater failed:
unreachable: curl: (22) The requested URL returned error: 404 Not Found

This is going worse and worse every update.

You can fix that by editing /etc/opkg/ and removing the stable-new parts, so, that for example, you have lines like

src/gz omnia_base

instead of

src/gz omnia_base

Do this for every line where stable-new appears.

After running, I’m now able to access the web portal. Thank you.

I did see the following errors returned which I’m assuming can be ignored.

WARN:Couldn’t read the status file: [string “backend”]:1333: [string “backend”]:1324: Failed to lock the lock file //var/lock/opkg.lock: Resource temporarily unavailable
WARN:Script revision-specific not found, but ignoring its absence as requested
WARN:Script serial-specific not found, but ignoring its absence as requested
WARN:Lock on //var/lock/opkg.lock released by garbage collector
uci: Entry not found
uci: Entry not found

@einar The funny part come when you don’t see stable-new there :slight_smile:

src/gz omnia_base
src/gz omnia_lucics
src/gz omnia_management
src/gz omnia_packages
src/gz omnia_routing
src/gz omnia_telephony
src/gz omnia_turrispackages

the issue is the updater.override.branch=‘stable-new’ in the uci show updater.

“src/gz omnia_base

two // are typo?

They’re unnecessary, indeed. But they’re harmless.

1 Like

Well, I replace the “stable-new” with “stable” in the override section and now, while my router is running, I can’t get in:

$ ssh root@
root@'s password: 
X11 forwarding request failed on channel 0
/bin/ash: No such file or directory
Connection to closed.

I did save off the all the failed update logs. I can post those somewhere. But how do I get my router back. Which reset option do I take?

Well, where did you read it? Try to go back to the last working snapshot:

I copied it off the terminal. I ran Was that a mistake?

Oh, and the instructions should specify which image to use when it comes to reflashing the emmc. The link goes to the right directory, but the file names are a little different.


It shall answer the moderator. I just thought that I don’t see “stable” anywhere here!
Also that I would come back to the last snapshot is just my opinion.

Ah, sorry, I was following a different thread because the updater was choking on the note about this that I found in /etc/config/updater:

in this post:

After I changed
option branch 'stable-new'
option branch 'stable'
and ran I could no longer get into my router (as in the beginning of this thread).

If I have to reflash the router that would be disappointing, but I’ll try the rollback and see where that gets me.

Yes, that was exactly my fast paced puzzle answer.

I’m happy to say the rollback worked flawlessly.

I’m holding off on updates though until I can see they’re ready for prime time.

1 Like