Enable VLAN checkbox and set VLAN ID

Hi there,

I am trying to setup my Turris Omnia router to have Internet access with PPPoE/DHCPv6 and in the WAN section in reForis I can’t find the following Enable VLAN checkbox as described here:

This is what I have:

I can’t see any VLAN options.

I found this documentation about VLAN with LuCI but is this what I need to use?

  • Turris OS: 4.0.1
  • foris version: 100.5


A hopelessly outdated version. Did you have a specific reason to freeze updates that are a major security benefit of the device? It would be advisable, I think, to update the system to the latest version before proceeding further, following the procedure in 4.

Then you would follow " PPPoE configuration" WAN - Turris Documentation

1 Like

Hi @JardaB,

Thanks for the answer, my bad I didn’t check if it was an old version!

I did the Reflashing procedure by downloading the latest version of the system image and also using the medkit-config.json file to setup the passwords but it seems I can’t login to the web interface ( note that it was working before the reset, my computer is connected with an ethernet cable to a LAN port).

The router is opened on port 22 for SSH but I don’t know the password since the reset.

In this thread people talk about restarting lighttpd but I can’t because I have no SSH access…

This thread seems to be exactly what I am facing right now:

How can I troubleshoot this?


Try without the json file. Perform full reset and go through the initial web wizard

I don’t like the password transfer magic. i would start with a factory reset, connect the cable to the router and go through the default wizard (if i understand your description correctly). Again you try to transfer the configuration between versions of the system that are completely different. The easiest way is the most reliable :slight_smile:

@xsys I tried without the .json file and I don’t know if it worked. I press the reset button until the first 4 leds are on (so 3 red and one green), the LEDs goes full green, restart and goes back to normal.
Then the power LED is green and the others are working correctly, if I connect with an ethernet cable I get an IP adress with DHCP but then I can’t connect to

@JardaB are you talking about a factory reset or a Reflashing of the router? I also tried the Factory reset (mode 3) but without any success, it’s not clear if the process is finished or not. Is the green power LED normal like it’s indicating progress and I need to wait longer?

Thanks again

unfortunately, it seems there is an old TOS version on your device. Could you contact our support desk and provide the diagnostics file via e-mail tech.support@turris.cz? We will try to help you.
Best regards
Marcela Turris Support Team

Hi @Marcela_Blazkova,

Thanks for reaching out, I suppose you are talking about this:

The thing is I can’t connect to SSH since I don’t know the password and it seems there’s no default password I can use…

Maybe I am not waiting enough after the Reflashing of the router? Or the USB key is not properly formatted?

Hi @johhnry,
I don´t know, where the issue is. However, the first step is to set up new passwords for reForis and LuCI. Follow the guide in our documentation.
https://docs.turris.cz/basics/reforis/guide/#setting-the-password Best regards Marcela

See Turris OS 6.0 is released - “Changed default colors of LED (e.g. Power LED is now green)”

1 Like

1 - First OS version update
2 - If you then did some onsuccessful steps → factory reset
3 - Initial wizard after system boot

I don’t get it why can’t he just use ssh to add a vlan option manually like this:
vi or nano /etc/config/network

config interface 'wan'
option ifname 'eth0' to 'eth0.201' .whatever vlan id you need
Other options are:
ipv6 '0'
option metric '10'
option proto 'pppoe'
change options for username and password
option disabled '0'
option peerdns '1'


Hi @JardaB,

This is exactly what I did:

  • Downloaded the latest medkit file omnia-medkit-latest.tar.gz
  • Copy this file on an Ext4 USB stick
  • Connect the USB key on the Omnia router back port
  • Press and hold the reset button to enter mode 4 (4 LEDs (Power, 0, 1, 2)) then wait for the Re-flash router operation to finish
  • The router updates and restarts, the power LED is now green meaning it updated to at least TOS 6.0
  • Connect my computer with an ethernet cable to the router, see the LED flashing for LAN0
  • Go to in Firefox

However I get Unable to connect in Firefox.

I can ping the router and doing ip route properly shows as the gateway.

I don’t know what to do. I tried doing a Factory reset after the Reflashing but it didn’t work either

Is there anything I can try to debug this?

Thanks again

Try other browser And https too.

Doing a nmap only shows port 22 and 53 open, it seems that the web UI service is not running. Changing browser or using https won’t solve the issue.

I can try to connect with SSH but is it possible to know what the default password is?

Edit: I found this in the docs

Unlike some other routers, Turris has no default nor hard-coded passwords. The Foris/reForis password is originally set in the first start guide. System passwords need not be set there but you won’t be able to log into LuCI nor access your router via SSH if no password is set for the root user.

I will have to advise someone smarter.

1 Like

@johhnry , when you go through the reset procedure, can you make sure that the router isn’t connecting to any other network device. Once it’s booted up only connect your PC via an Ethernet cable. This is to make sure that there isn’t any network issue that might prevent the webserver from starting.

In parallel to that: Are you able to connect to the router via a serial cable? I.e., do you own such as cable?

Hi @dhopfm,

Thanks for the answer, what I tried:

  • Only connect the router to the power supply
  • Do the Reflashing procedure by pressing the reset button
  • Restart the router after it finishes
  • Connect my computer to LAN0 with an ethernet cable
  • DHCP gives me ipv4/6 address, can ping the router
  • Unable to connect to

Do you mean using an UART cable like mentionned here: Serial connection - Turris Documentation?

Also maybe I can try flashing a previous OS version?

Yes. This would allow you to login without a password.

Do you have any cards installed in your Omnia? If yes, can you remove all of them and try again?

I solved it by downloading and re-flashing the medkit version 6.3.0 (in the archive)!! :partying_face:

Now I have internet access and I could setup the VLAN ID properly, thanks to all for helping me!

(Maybe it’s an issue with the latest OS version…)

1 Like