Enable second Ethernet WAN connection

I have 2 broadband connections, one fiber and one cable. Both provide RJ45 Ethernet connections. I’m running TurrisOS 4.0.2 and I am preparing to implement mwan3.

I completed the following:

  • removed LAN4 from the LAN group “br-lan”
  • configured a new interface “vlan3” and included LAN4.
  • created a new interface “wan2” and added vlan3.

With the WAN cables attached to the LAN4 and WAN ports, the LuCI interface shows WAN and WAN2 connected.
when I connect to the router with SSH it is able ping google by IP but not by name.

# ping -c 1 -I lan4
# ping -c 1 -I eth2

The LuCi interface does not have a “switch” menu under the network category.

Also when creating vlan3 and wan2, some of the defaults may need to be changed.

  • “use default gateway” is checked
  • “static address” is the default, but I changed it to “DHCP client” when I created vlan3 and wan2
  • perhaps other defaults also need to be changed

According to Multi-Wan with OpenWRT / Mwan3 OpenWrt should be able to accomplish this. Any guidance specific to the Turris Omnia is welcome.

ping works but DNS resolution does not? :thinking: For multi-wan especially I’d certainly avoid using forwarding to ISP’s DNS servers, because you’d most likely have to switch the forwarder IPs whenever “switching the WANs”… and there’s little advantage in it anyway – I’d personally recommend mode without forwarding (just uncheck the option in Foris / DNS) or you might choose a provider from the list (stable target across ISPs).

DNS forwarders are set to public resolvers (google and

I deleted the two interfaces I created vlan3 and wan2.
Then I created a new interface “wanb” and configured it to be a bridge that includes interfaces eth1 and LAN4.

The next step was to install two packages:

Now I have a broadband connection enabled over the WAN port and separate connection over the LAN4 port.

The google option in Turris has a bug (CZ thread). You can use something different for DNS for now or you can simply add one line port="53" into /etc/resolver/dns_servers/99_google.conf.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.