Easy configuration script for movistar ISP ftth fiber (spain)

Hi there!
I’m trying to make the turris work with Spain movistar ISP fiber connection. I’ve got no idea what I’m doing, but at least it works now. I expected the router would just work when I plugged it and switched it on, but it didn’t.

However I found this script that configures it for you. I would really preffer to be able to configure it manually, how would you do it? What does this script do? So that I could do it with just with the fortis or luci interface

This are the steps I’ve done, in case others need it:

Setup a fortis password, cofigure everything and then setup a luci password in the ‘Advanced administration’ menu

Download the movistar.sh script from here:

link is taken from this forum:

(the password will be the one you’ve set up for the luci interface)

ssh root@


scp movistar.sh root@

ssh root@

cd /tmp

chmod +x movistar.sh


You will get this:
(note: I’m not sure wich port should be chosen to connect the turris to the internet, I’ve chosen port 4, the one near the wan port, would this be right? at least it works now)

Movistar FTTH Configuration Script r21
OpenWrt omnia 15.05 (mvebu/generic)
Alvaro Fernandez Rojas (noltari@gmail.com)

Router not supported.
You need to set the switch config manually.
Switch Info
Switch Ports: 7 [0 1 2 3 4 5 6]
Switch CPU Port: 5
Switch WAN Port: Unknown
Switch LAN Ports: Unknown

Please specify WAN port number

Switch Info
Switch Ports: 7 [0 1 2 3 4 5 6]
Switch CPU Port: 5
Switch WAN Port: 4
Switch LAN Ports: 0 1 2 3 6

Customize LAN Network? (def (y/n)

Enable VOIP? (y/n)
Enable IPTV? (y/n)

Network config erased
Network config loaded
Network config applied
Firewall config saved
bird4 config applied
DNS rebind protection enabled

Configuration done!
Make log persistent? (y/n)
root@turris:/tmp# poweroff && exit

1 Like

Noltari´s script works with turris?

I configured movistar FTTH manually, it´s very easy and discussed in this other post:

But it´s only for internet access (i don´t have TV or Phone over internet). Please let us know if the script works with turris.

I can confirm it works. I manually changed the variable switch_wan_eth1 to equal 1 in the script. Also, make sure all dependencies are installed (swconfig, bird4, mcproxy o igmpproxy, kmod-bridge, kmod-ipt-nathelper-rtsp, udpxy [optional]).

I am now trying to set this up with the Mikrotik SFP ONU module to skip the ONT device. No luck yet. See SFP Module advice.