Dynamic DNS timer not working?

I have set the Dynamic DNS via LuCI > Services > Dynamic DNS and I haven’t touched the default Timer settings. Two days ago the ISP changed my IP, however I’m still seeing my old IP (smeared in the picture) in the Dynamic DNS settings. As a result turris is not accessible from the internet using dynamic DNS name.

Moreover, the last update is always current date (minus some minutes) and next update is current date plus three days.

Maybe the default Timer settings are not active?

I would say, test the functionality if it does work at all. Stop the service and restart it again and then check if you get a new updated ip-address.

In the Advanced settings–>IP address source [IPv4]

I have in my configuration used “URL” instead of the other three. URL one can be sure of that it will grab the “wan/internet”-ipaddress. Try that and see how things will go.

IP address source is the default “Network”, and it was working fine before the IP change, I still see my old valid IP, before the change

the strange thing in /var/log/ddns/myddns_ipv4.log is, that there I can see the correct new IP, but there is an error authenticating to no-ip.com using wget, very strange

I’ve checked the password, let’s see…

now everything is fine, must have been some strange problem with the password, maybe on no-ip side?

it would be better if LuCI shows some error message though, not just old IP and current date as Last update

I have also no-p.com and been using URL. No problems till now.

OK, I’ll change it to URL to be sure

in /var/log/ddns/myddns_ipv4.log I can see valid IP, but sometimes there is just

If you see, it looks like if the WAN-IP is not being caught, then it sees only his own default…loop address.

Using URL, it is either “no-connection” or “WAN-ip-address”. If there is no-connection then for sure you will notice it right away.

EDIT: BTW, we can use the URL-checker…to be this “” instead of “http://checkip.dyndns.com”. It point at the same DNS, but if DNS-settings somehow doing something odd…the “check” will always be valid…until those guys change IP-Address XD. I think no problems will occur for now using the “http://checkip.dyndns.com”.

I often use http://ipv4.icanhazip.com for IP checking. And ipv6 equivalent.
And if you want another dyndns provider, you can use a project from friends of mine shameless ad http://www.owndns.org /shameless ad