DSL-2641R router as a modem in connection with Turris Omnia, dual router setup

Hi Guys,
I have the following setup and can’t make it right. I have a DSL-2641R router from Slovak Telekom that supposed to work as an ADSL Modem. The Lan port ftrom DSL-2641R is connected to the WAN of Turris.

My dream setup: DSL-2641R only as a modem no routing no NAT, on firewall and WIFI Accesspoint .
I have tried several configuration but neither of them work stabil:

Turris: DHCP on network 192.168.2.XXX, static IP for the WAN,
DSL-2641R: DHCP on network 192.168.1.XXX
In this case the setup works for few days, than suddenly no internet is working. I restart both routers

Turris: DHCP on network 192.168.1.XXX, static IP for the WAN,
DSL-2641R: DHCP off
In this case there is no internet at all. I supose I would have to config a static route to the DSL-2641R but I have no option for that on the Admin interface.

There is an option “Default Router” in the PPP settings, but if I turn it off I can’t save the config saying I have to have at least 1 default route.

Turris: DHCP off, static IP static IP for the WAN,
DSL-2641R: DHCP on
Here the internet worksbut in such case if I understand right turris is just a WIFI AP so no NAT no real firewall option. And I really want Turris to be the default router so I do all cool and nice stuff throuhg her: the NAT, PortForwarding, VPN ,DMZ, etc.

I have seen that I could switch the DSL-2641R in ADSL Bridge mode. But that Turris would have to connect to the DSL. Would it work over WAN and how to set it up? Any help is highly appretiated.

Bridge is transparent!

Thank you for your rush response. I tried it but there was no connection. I checked the logs but couldn’t identify any reason. Here are my settings DSL-2641R, turris is like on your screenshot but with my CHAP infos…

One more thing, if I tried to setup chap from Forism than the interface has crashed… I I posted a bug report

Any ideas?

As a workaround you can put your turris on local IP into DMZ zone at your ADS Router. e.g. set port forwarding of all ports to your turris ip. ADSL router will then send all traffic to turris.

Now it works. The problem was that the DSL-2641R was not connected to the WAN. Never-ever-trust anyone Even if they swear that they have connected it correctly. My brother-in-law has connected it to the LAN port. The DSL-2641R is in the other hous, and the router is located on the attic, so I trusted him. Only after hours try I went to the attic…

Thanx for the help…