Downtime notifications linked to something going wrong with name resolving?

Over the past days I get regular downtime notifications where I’m pretty sure that my Omnia wasn’t down at all.

On get these kind of messages:

Error from 2017/12/20 05:52:15
Updater failed:
unreachable: Couldn’t resolve host ‘’

Doing the Connection test I get 6 OKs:
Connection test

Here you can test your internet connection. This test is also useful when you need to check that your DNS resolving works as expected. Remember to click on the Save button if you changed your forwarder setting.
Test type Status
IPv4 connectivity V
IPv4 gateway connectivity V
IPv6 connectivity V
IPv6 gateway connectivity V

Could this be related to the issue that I tried to describe here?

Same problem here. Getting daily downtime notification emails for a few weeks now. TO seams to work fine, read no problem with internet, GUI is accessible. The LED rainbow is not working, though. All LEDs are lit in standard color. And haven’t got any updates since then. Rebooting the device makes no difference.
Has anyone an idea how to fix or at least investigate further?

I also go those issues. That was because it couldn’t resolv itself. After looking at /etc/resolv.conf, it was directing to This could be usually normal (for LAN DNS to work i guess), but it couldn’t resolv a dns itself. So when i changed it, it worked again. However after some time it will change back to

I think the problem lies with some change in the last update, because before that i did not have any problem as the resolving of the addresses worked just fine.

For now as a work-around, try to use the workaround of placing your resolv.conf somewhere and pointing to that file in the /etc/config/dhcp under dnsmasq.

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option nonwildcard '0'
        option port '0'
        list server ''
        list server ''
        option logqueries '1'
        option resolvfile '/mnt/LXC/backup/resolv.conf'

It is always good to mentioned which resolver is in play, e.g. dnsmasq, knot, unbound etc, in order to narrow debugging. is commonly the address of the local resolver and thus remain in resolv.conf unless otherwise specified

1 Like

For now as a work-around, i made a cronjob copying a resolv.conf to /etc/resolv.conf every minute until there is a fix.

This is a very nasty workaround. Honestly, you don’t want to do it.
You’re just hiding the real issue here and each minute you’re writing on eMMC, which will result in dead eMMC sooner or later.

Hi there!

Can you tell me which daily downtime notification emails do you get? Do you mean email notifications from data collection or from Updater?
I just want to be sure, because OP is saying that he couldn’t resolve host

Updater checks every 4 hours if there is an update available.

You are ABSOLUTELY RIGHT. I TOTALLY forgot about it.Thanks for pointing that out.

During the previous day, following downtime of your router “LRW” was recorded:

Firewall: 24 hours
uCollect: 24 hours

The total sum of outages is currently 813 h.

You’re receiving this email because you have enabled sending of notifications about your router downtime.
You can disable sending of these emails on the settings page:

This is an automatically generated email, please do not reply to it. If you need to solve any problems with your router, please contact us at

The team of project Turris

This email tells you that you have an issue with sending collected data. Anyway send me all diagnostics, which you can generate in the user interface Foris to and I’ll help you.

@Pepe email sent! Thanks in advance

A post was split to a new topic: Downtime notification