Download bandwith problems Init7 (Hybrid7) with SFP

Hello people,

I have since 2 weeks the Turris Omnia, and this forum was really helpful with Vlan-Tagging etc.

My configuration:
Turris Omnia 2018
TurrisOS 5.1.4
Kernel: 4.14.206
SPF: Universal 1G SFP Wide BiDi LX LC-Simplex 10km, ᵀˣ1310 / ᴿˣ1460-1580 nm, Singlemode, 125Mbit/s - 1.25Gbit/s (Flexoptix)
Connected directly to the OTO via 3m fiber patch cable (ITU-T G.657.A1)
ISP: Init7 with Hybrid 7 1Gb/s synchron
Windows 10 PC with Cat6 patch cable.

It works Ok for me, but there are some things I don`t understand.
Using NetMetr with Forris will get Download 330Mb/s and Upload 910Mb/s
Speedtest.net will get max. Download at around 300 to 550Mb/s and Upload 600 to 750Mb/s (With Firefox, Opera, Chrome and Edge)
Iperf3 shows similar speeds.

I tried on 3 different devices (Windows 10), all with Cat6 and Cat5e patch cable and deactivated firewall.

On the Turris Omnia, I deactivated the adblock and QoS, removed the monitoring packages (pakon, suricata, etc.
Still not reaching the 900Mb/s not matter what.

Maybe important:
The CPU load goes up to 100% while upload.
While making a speedtest, the luci real time diagram shows some really high peak bandwith > 1Gbit/s

Is there something I´m missing or is there some tweaking necessary for gigabit speeds?
Should my ISP change something to improve things?

Thank you in advance!

Cheers,
vulgogurktaler

1 Like

when I tested 1gbit speed with my omnia, I was able to reach ~937 Mbit/s max. That included direct ethernet cable between omnia and PC (tested with laptop too).
I guess this is kind of maximum we can get on so-called gigabit ethernet.

Your problem might not be omnia.

tried runnins “iperf3 -s” on omnia, and connecting to it from your PC?

1 Like

@fantomas thank you for the reply.

Yes, 940 Mbit/s should be the absolute possible maximum on gigabit.

I did the iperf3 test on the laptop:
Laptop -> Omnia I get 886 Mbit/s (Connected directly to the Turris Omnia)
PC -> Omnia I get 889 Mbit/s (Connected directly to the Turris Omnia)
PC <-> Laptop I get 939 Mbit/s (Both connected directly to the Turris Omnia)

any other packages installed? Dynamic firewall enabled?
have you rebooted after 5.1.4 update?

i checked iperf3 and yes, CPU usage is high, but not 100%.

…can you replace the SFP module by other? I use ethernet, ISP provied me their modem in bridge mode.

No, I deactivated/removed everythin unnecessary…
Firewall enabled and also disabled, did not change anything.
Yes I made the reboot this afternoon.

That was I was also thinking, I will get a new SFP-module by end of this week, though It is still from the same manufacturer…

Maybe I should order the SFP module from my provider, but for now they really could not find any issues.

maybe you can just borrow one, to see if it’s the problem.

did the problem appear before 5.1.4 ?

Not quite you can theoretically reach a bit higher, but only a bit. The cause is obviously that the nominal 1000Mbps are a gross rate while what you measure is a net rate, tupicakly the TCP payload rate (often called goodput).

1000 Mbps * (1500 - 20 - 20) / (1500+38) = 949.28 Mbps

But that is the theoretical limit you can at best see if you do not use more per packet overhead.

I ordered it already, since I don`t know anyone who can borrow me the SFP-Module.

No, I was already before that. Since I have the Turris Omnia.
Before that I had a Netgear Nighthawk x10 and thought this is the bottleneck…

Yes, between Laptop and PC I can reach that.
Speedtest_Intern

Update on this:
I exchanged the SFP-Module and still not really a change.
Only the upload is slightly faster, but that might just also be due to availability from the speedtest-servers.

Work laptop with activated VPN gets me also around 400 Mbit/s Up and 700 Mbit/s down…

I have uplink connected using huawei echolife HG8245H GPON terminal in bridge mode provided by my provider. it provided 1gbt/s when I tested it (i only have 500m link now)
can you try ethernet bridge like that one?

1 Like

Try HG8310M instead.

1 Like

whatever, we wish you good luck :slight_smile:
I have no SFP module, and I’d have to argue with provider to use one.
Yes, I 'd prefer avoiding another device…

1 Like

Equivalent for HG8245H and HG8310M is MA5671A SFP. Unfortunately, it’s not supported by the TOS kernel.

1 Like

@fantomas @viktor
Thank you for your advise and for trying to help me.
I didn´t order a router from my ISP.
I don`t have a GPON-FTTH connection, it is a bidi Single-Fiber connection.

I gave the support a call yesterday, and they said my measurements make no sense because it should have the same Up/Down speeds…
Also my ping with 12 ms is quite high for fiber connection.

As with the information right now, the problem might be with the ISP init7, not the Turris Omnia.