Downgrade from turris 7

i am having nothing but problems with turris v7. I do not see a way to enable ssh, There is no way to create backups, there is no way to reflash directly from LuCI, ever since i installed openVPN on it, i lost my internet connection and could not get it back until resetting. I want to go back to os 4.01 (which is how my router came) and then use Luci to reflash with openWRT. Any suggestions will be greatly appreciated

reflashing to any version is done by 4 LEDs: Re-flash router from flash drive
Old images are here: https://repo.turris.cz, particularly at Archive of all released Turris OS versions

THANKS SO MUCH!!!
I spent hours searching for this but could not find it

I have another question (different topic) perhaps you can answer here?

I have been trying to make a tun interface, but after creating an openVPN instance, the “add interface” page does not contain an option for tun (under the device menu). How do i make a tun interface? Will an eth interface work for an openVPN tunnel?

Sorry I don’t have any knowledge here, try OpenVPN server - Turris Documentation and search this forum.

there is nothing i could find in any turris documentation. I will make a new post in a different topic. Thanks again for your link to the turris os archive

can you advise me how to format a usb thumb drive with ext4?

i am on a mac

Well I need to step in. You are badically moving to vanilla OpenWRT so you loose support here. Also you ask basic guestions that you can search for using your favourite search engine on your Safari. Its offtopic

1 Like

with all due respect AreYouLoco. . .although i do plan to move to vanilla OpenWRT, i have not done so yet and i seek support for a turris issue. I am trying to create a usb thumb drive for an older turris os. Thanks to xsys, (who provided me a link to turris os archives, that i was able to find in any turris docs) i now have the image file i need, but i still have not figured out how to format the usb drive. My attempts to do so via the reforus gui (http://192.168.1.1/login?/reforis/storage) have failed, so i seek support from anyone who can tell me how to make the USB drive with an ext4 format (i am on a mac, but i may be able to find someone with another platform if required)

In my view you are clearly seeking advice on how to format a pendrive. Which is general knowledge.

I will give you a pointer mkfs.ext4 no matter how bad are you at searching internet this should take you around 30seconds. Max 5 minutes if you have some disabilities (with all the respect if you happen to have some) and you would have a satisfaction that you actually used your own brain to do that simple task.

Secondly why would you even want to flash older turris version just to overwite it with openwrt. Its also stupid. Just go straight to flash openwrt using their docs.

Just keep in mind that openwrt uses different filesystem and partition layout.

And also just a friendly caution. I am 90% sure you are going to get a brick when you flash some old not supported turris os and write openwrt from Luci. Did you take into consideration that there is something called U-Boot? A bootloader and it has some enviormental variables for turris os and different ones for openwrt?

Did you even bitten-Apple searched for this page:?
https://openwrt.org/toh/turris/turris_omnia

That gives you all the steps needed to flash openwrt?

It might sound like an attack. And it is. Do your own work before you ask for the basics of the basics. And I bet you didnt even spend 5 minutes doing research on that subject.

Edit: and yeah welcome to the community because its your first topic😆

1 Like

i am unable to figure out how to enable SSH with turris os7, so i have no way to do the mkfs.ext4 command. Can you tell me how i can enable SSH?

The reason i need the older version of turris os is because turris os 7 does not include a version of LuCI that supports flashing or creating backup archives

My router came with turris os 4, but after it crashed, i tried a reset with 3 LED, but it did not revert back, so i did reset with 6 LED. That is how i ended up with turris 7.0, which i seem to be stuck with, unless i can get back to turris 4, which includes a version of LuCI that does support flashing and backup/restore functions.

The point which you do not seem to get is that i have no SSH access (and have no way to enable it, despite me having checked the reforis option to “use the same password for admin”), and as i already explained, the version of LuCI, that comes with turris os7 is extremely limited (compared to the one that comes with turris os4), which is exactly why i want to revert back to turris os4

I will take the high road and not respond to your self admitted attack and insults, I just seek answers to my core questions:

How can i enable SSH access?
How can i get a version of LuCI that supports flashing?
AND if you can not answer those questions, then
How can i create a USB pen drive formatted with ext4 (when i have no ssh access)?

thanks in advance for any useful response that you may provide

There is no need to enable SSH access, just connect with some ssh client to your router IP (default is 192.168.1.1) and login as root and with your password.

Format pendrive to ext4 - you can try this: Reddit - Dive into anything
Or, better use some live linux usb and use GParted (be careful what drive you are going to format then!). I didn´t know, that Mac is so crippled…

Backups are made via reForis…

Flashing is possible via reset button (4 LEDs - Omnia - Turris Documentation ), and I believe that way could be installed any supported OS to the Omnia, but didn´t try that with other OS.
This way it is possible to flash TOS4 directly and it is enought to format pendrive to fat32 only, which Mac is supporting, so half of your problems would be solved.

And the main question is:
What are your exact problems with TOS7 except that, you are unable to connect to SSH? Did you try reset to factory settings (via reForis or 3 LEDs) and set it from scratch?

This is because TurrisOS differs from stock OpenWrt in how the filesystem is laid out. Stock OpenWrt defaults to a read only filesystem for the initial root and a writable overlay filesystem so you can apparently change files after the fact (you never change the files in the read only file system though so you can always revert back to that state). Flashing means mostly replacing that read only filesystem with a new/different filesystem image. TurrisOS however operates / as a real read-write filesystem using btrfs… so not offering the OpenWrt flash controls in TurrisOS is a feature, not a bug, as that would give naive users enough rope to shoot themselves in the foot…

If you want to switch to OpenWrt, follow the instructions from the OpenWrt wiki…

That is incorrect as well, read here:

for how you can leverage btrfs’ capabilities for backups and the like.

Ah, you might just need to revert to the btfs snapshot from just before trying to install/configure OpenVPN then…

2 Likes

i have tried to connect to 192.168.11 but the connections is refused. In openWRT, i did not have this problem . . .i just enabled ssh and connected w/o any problem

problems with TOS7? lost internet connection after installing openVPN and could not reconnect until reset to previous snapshot, Can not create backup archives or flash with LuCI

thanks so much michalko58 and moeller0 for your replies!

According to the SSH - is the same at your side as here?

This helped me:

You can try Wireguard, which is better than OpenVPN, but is not supported in reForis.
But I don’t get what you mean with snapshots, which are fully manageable via reForis:

thanks for your reply, i will fool around with ssh client settings. Yes i do see that reforis does handle snapshots, i was referring to the LuCI backup page, which is missing now. I guess the reforis snapshots will serve the same function

I am running 6.5.2 on my Omnia and both SSH and OpenVPN work fine as configured through reForis. I didn’t look at upgrading to 7 yet, I’m kind of waiting for some minor versions to pass by before moving there. Let it know if you cannot get this to work with 6.5.2.

Note that I tried WireGuard as well, but I believe I ran into some bugs. I intend to try it again in the future (with a higher Turris OS version).