Do I still have a mdadm RAID?

Hello everyone,

I created a RAID1 array over sda and sdb using mdadm. Unfortunately, I do not remember the details how I did it.

However, for some reason I checked it again some time ago and I feel I actually do not have a raid (anymore).

If i use btrfs filesystem show, it looks correct, since both drives have the same space “used” and it is under the same label.

However, when I use df -h and lsblk it looks to me as if only sdb is mounted.

Also, using cat /proc/mdstat does not give me any results. It only gives me a list of the ‘personalities’, but does not list any devices.

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath]
unused devices:

I’m really confused. How do I check the status of my RAID array?

Sounds like RAID1 directly on btrfs level – that FS can do such things. (By a quick look; I’m no real expert on this anyway.)

1 Like

mdadm -D /dev/sdb1

Tried it. “/dev/sdb1 does not appear to be an md device”

´cfdisk´ also does not show a RAID.

It is not part of a RAID(1) array then and just the mount point is /mnt/raid1

that’s what I assumed. But why do both have the same available space then if I don’t have sda mounted to anything :thinking:

Is that supposed to be software raid on the same hd and not a hardware raid of 2 different hds (sda & sdb) of each equal 3.7T capacity?

If indeed the former you may have split the single drive into equal partitions but never activated the array since the creation is not the end of the process, in any case.

You sure that array ever been active?

I remember writing cat /proc/mdstat to check how far the creation of the array is. So I think there was an array once.

I am actually trying to make a RAID1 over two separate drives with 3,7 TB each.

Thank you so far. I guess I need to copy the data somewhere and recreate the array.

maybe not at all. Did a bit of reading and now understand that btrfs has the capability of a software RAID (block group profile type that utilizes RAID-like features on multiple devices: striping, mirroring, parity) but not hardware raid.

Thus perhaps

is a result of a btfrs software RAID(-like) running on your system

That would explain this:

Guess I used btrfs to create the RAID and not mdadm. Thank you guys very much for the support!!

Edit: OK, the mount is /mnt/raid1 and using btrfs fi usage /mnt/raid1 gives the following:

I did the raid1 with btrfs. I feel stupid now. I think I also remember now. The creation of the RAID1 using mdadm was putting a very high load and for some reason caused the creation to fail. I then tried with btrfs and it worked…