Dnsmasq ignores /etc/hosts

seems that dnsmasq ignores /etc/hosts now.

last time it did when I ran dnsmasq with “port 0” for DNS, I have solved that by running dnsmasq on different port

I set dnsmasq to port 54 or 53 (moving kresd to 54), neither did help (it did before 6.x)

/etc/hosts is great database shared for DNS and dhcp.

I’m member of dnsmasq mailing list, will ask there.

but this is requirement for me, I’m going back to 5.4.4
(not pre-update snapshot, that caused update to repeat)

As dnsmasq does not do DNS by default on Turris, your question is just about the DHCP part, right?

  1. yes the problem applies for DHCP.

  2. DNS hard to say, because dnsmasq sent REFUSED for every query from internal network.

I used dnsmasq for DNS resolution before.

On 6.0.1 this problem did not reappear.

Note that DNSmasq seems to ignore hosts files if it runs with “-p 0” which turns DNS off, and this is the default on Turris OS.

Also, host names in /etc/ethers must match those in /etc/hosts, including the domain part - while dnsmasq does support appendign domain to DNS names, this doesn’t seem to apply to DHCP host matching.