DNS stopped working (AGAIN)

Hi, somehow with new year my internet connection stopped working. For me it looks like DNS stopped working at all.

Wifi works, I receive IP address, anyway nslookup does not find results. I have no idea, why.

dnsmasq restart looks a bit strange as well.

Did you try disable DNS forwarding?

Notice that unless you have changed it the DNS is handled by kresd (Knot resolver).


in basic web admin i tried to disable forwarding, as well as DNSSEC. Unfortunatelly, no change, still does not work.

I have tried to restart dnsmasq, because i hav local dns requests forwarded to port 54, where my dnsmasq is running.

The only solution now working is, that I have my older TP-LINK connected as router and turis is connected via cable to LAN port, so in fact as AP. So whole routing part going through WAN I just don’t use. But of course, its not a solution.


DNS stopped working again. nslookup returns timeouts and in basic web admin page its like this.

No changes done on router for several days. last time it happend i had to use second older router and turris use as simple AP. After few days i reconnected and worked back. Now after another few days again DNS problem.


Sorry for bad english.

I have been here for 41 days and have been discouraged! There is no progress.

All work hard, perhaps a break would be necessary.

There are errors with every version! Logical priorities do not seem to exist.

Two Omnia routers I have in use, so 1 works minimal

I again had to take my older router, which works fine and now AGAIN turris is used as only simple AP, because through WAN DNS just does NOT work.

Its a bit expensive solution, I think turris is the most expensive AP I have ever had.

Can finally some official support advice something??

yea, looks to me, they shipped as soon as it wasn’t totally broken.
maybe give it half a year before using in production, if you rely on foris to diag stuff

Well, but how to debug or check in detail, where the problem might be? It looks for me like local kresd does not work at all or stop to forward dns requestes. Unfortunatelly in system log there are no messages, only that he cant reach api.turris.cz, which is logic, without DNS.

Currently kresd doesn’t “know” how to switch the next DNS server if you have defined more than one as forward DNS servers and the first one stops responding. So check if changing the order of DNS servers helps.

You can also connect to the kresd process by command

socat - UNIX-CONNECT:/tmp/kresd/tty/$(pgrep kresd)

but then you need to know how to speak lua language.

well I guess if I use dnssec then its completely under control of router. I don’t have any special dns settings. even if I used only one and switched dnssec off, it did not help.

If you have defined DHCP for WAN then DNS is under the control of your ISP. You can check the kresd’s configuration by looking in to the file “/tmp/kresd.config”.

no I have no DHCP on wan, only on lan and guest network.

Updated to 3.5 and works now. Hopefully will work longer then only few days.