Disable 2.4 GHz band in WLE900VX WiFi chip

I have a custom piece of software that expects a WiFi interface supporting only the 5 GHz band. Since the WLE900VX chip is dual band it doesn’t work correctly.

I would like to disable the 2.4 GHz band. I see I can do this, at the very least, by using the ieee80211-freq-limit devicetree property (https://github.com/torvalds/linux/blob/master/Documentation/devicetree/bindings/net/wireless/ieee80211.txt#L7), but I’m not really familiar with devicetree.
I still have to try, I guess I will start with something like

pcie@2,0 {
        /* Port 0, Lane 0 */
        status = "okay";
        wifi@0,0 {
                reg = <0x0000 0 0 0 0>;
                ieee80211-freq-limit = <5000000 6000000>;

in armada-385-turris-omnia.dtsi. But, even if it seems to work, I will still keep wondering if I have broken something subtle.

Does somebody know exactly what would I need to do to disable the 2.4 GHz band (i.e. make iw phy0 info print only one band) in the WLE900VX interface (via devicetree or any other way)?


Not the solution to setting up wifi in Foris ? Alternatively reset wifi and new setup … ?

I don’t think so.

I can easily manually configure the WiFi interface to use one frequency/band or another. But I’m not trying to use the WiFi interface as an access point or connect it to an access point, I’m trying to use it with a custom piece of software that wants to set the frequency itself.
The software is not smart enough to handle a dual band interface, so I really need to make it look as a single band WiFi interface to user-space. That’s why I was looking at ieee80211-freq-limit.

I believe you will also need to patch the wireless drivers to pretend the card is 5GHz only.
But, in my opinion, you should fix the crappy software that cannot handle the dual band card.

You are right, the correct fix would be to fix the software. But I was hoping for a quicker (it’s conceptually simpler, even if I don’t have the expertise) fix via ieee80211-freq-limit (the driver already has the patch: https://github.com/torvalds/linux/commit/34d5629d2ca89d847b7040762b87964c696c14da).