Difficultly assigning VLAN to WAN correctly

I’m attempting to create a VLAN and assign it to the WAN port, but without success.

As such, I renamed VLAN 2 to 201 and tagged port 6 (CenturyLink requires its network traffic to be tagged 201).
I assigned the WAN to VLAN Interface: “eth0.201”.

The resulting /etc/config/network:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd22:91e8:0e0f::/48’

config interface ‘lan’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option _orig_ifname ‘eth0 eth2 wlan0 wlan1’
option _orig_bridge ‘true’
option ifname ‘eth0 eth2’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0 1 2 3 5’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘4 6t’
option vid ‘201’

config interface ‘torguard_vpn’
option proto ‘none’
option ifname ‘tun0’

config interface ‘wan’
option proto ‘pppoe’
option username ‘user@qwest.net’
option password ‘password’
option ipv6 ‘1’
option _orig_ifname ‘eth1’
option _orig_bridge ‘false’
option ifname ‘eth0.201’

config interface ‘wan6’
option ifname ‘@wan
option proto ‘none’

When I use LAN0-LAN3, I get a local IP, but no access to the internet.
When I use LAN4, I get IP 169.254.134.152 and no access to the internet.

What am I doing wrong? Am I missing the LAN assignment?

Eventually, I’d like:

  • LAN4->port 4->port 6->eth2 to be an encrypted connection to the ISP, assigned to one of the two WiFi cards
  • LAN0-3->port 0-3->port 5->eth0 to be an encrypted connection to my VPN provider, assigned to the other WiFi cards

Help is really needed and appreciated.

Ugh, so simple. Add a custom interface as specified in this thread: Help configuring VLAN for WAN.

Contents of /etc/config/network:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd22:91e8:0e0f::/48’

config interface ‘lan’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option _orig_ifname ‘eth0 eth2 wlan0 wlan1’
option _orig_bridge ‘true’
option ifname ‘eth0 eth2’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0 1 2 3 5’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘4 6’
option vid ‘2’

config interface ‘torguard_vpn’
option proto ‘none’
option ifname ‘tun0’

config interface ‘wan’
option proto ‘pppoe’
option username ‘user@qwest.net’
option password ‘password’
option ipv6 ‘0’
option _orig_ifname ‘eth1’
option _orig_bridge ‘false’
option mtu ‘1492’
option ifname ‘eth1.201’