DHCP serves as DNS server

I just flashed my Turris Omnia with the latest medkit to find out I’m now on Forris 5.

I use a LAN network of so I changed this in the setup. Now my clients are served a DNS server of which makes the network fail. seems hardcoded in the dnsmasq setup.
/var/etc/dnsmasq.conf.cfg01411c contains:

I’m not sure what the exact place is to fix this but I think this is a bug in the first place



I’m not sure what got wrong in your case, but it is not “hard-coded”. I’m using a different network prefix and this part of config got generated correctly (though it was months ago).

As a quick mitigation, I’d try to go to the Foris GUI, tab LAN and change router IP to something else (and e.g. back later). I tried now on TOS 5 (HBT) and it seemed to change correctly, including the DNS address served over DHCP.

EDIT: on these kinds of changes I think you may need to disconnect the client to trigger new DHCP exchange (at least for my wired one it appeared so).

I don’t think I did anything special. Just after flashing I used the Forris interface to setup the LAN.

I fixed it using some uci command I found on the openwrt forum. Since the dns server is a config line in /etc/config/dhcp it just changed that line. The config now reads:

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	list dhcp_option '6,'

slightly different from: dhcp-option=lan,6,

It works for now.