Debian 9.6 - odstranění knot-resolver


#1

Pěkný den,
náhodou jsem si dnes všiml, že v rámci vydání Debian 9.6 byl odstraněn balíček “knot-resolver” z důvodu bezpečnostních problémů. Vím, že politika Debianu může být pro někoho z hlediska správy starších verzí balíčků problematická, přesto, není to škoda? Budete se nějak snažit vrátit balíček do dalšího vydání nebo bude k dispozici až opět od verze Debian 10?

https://www.debian.org/News/2018/20181110
https://packages.debian.org/search?searchon=sourcenames&keywords=knot-resolver


#2

Bohužel politika stable Debianu je neslučitelná se stavem projektu knot-resolver. Občas jsme objevili bezpečnostní problém jehož oprava vyžadovala velké změny – což oni nejsou ochotni akceptovat (kromě výjimek jako Firefox).


#3

Aby to nezapadlo, udržujeme vlastní balíčky pro řadu distribucí, včetně Debianu 9.x, takže uživatelé nejsou závislí na oficiálních repozitářích.