DDNS no-ip.com provider missing

After update to version 3.3 no-ip.com provider in DDNS settings was missing. Why? Can you put it back?

this is interesting for me too…

Install it back, search ddns-scripts_no-ip_com in LuCI

2 Likes

You need to add this line to /etc/updater/user.lua

Install "ddns-scripts_no-ip_com"

This ensure that this package will be preserved next turris update.

3 Likes

it’s working, thanks

I’m curious why it was removed at first place, I come to work thinking that will not wait for Sunday for reboot after update… did the reboot now half of my stuff is not working :frowning: dynamic DNS is missing no-ip while I was using it, local DNS is not resolving local network again, which mean samba shares are not working… awesome… thanks for update…

LoL I just tried installing it via LuCI and the whole web interface crashed…

removed tag solved
for me add via luci was working, others problem I didn’t found, yet

I got this message:


• Removed package ddns-scripts_nsupdate
• Removed package lxc-autostart
• Removed package luci-i18n-wshaper-cs
• Removed package ddns-scripts_no-ip_com
• Removed package luci-i18n-wshaper-en
• Removed package ddns-scripts_cloudflare
• Removed package kmod-crypto-rng-jitterentropy
• Removed package luci-app-wshaper
• Removed package wshaper
• Removed package ath10k-firmware-qca988x
• Removed package kmod-ath10k

I’m waiting for automatic restart. I want to try how it works. Then I will see what works and what doesn’t.

It seems to me this was not removed, but rather reorganized, by the makers of the ddns_scripts package (so not by Turris). Anyway, on the top of the Services/Dynamic DNS page is a link to the (OpenWRT) DDNS Client Documentation. On that page is a table with DDNS providers, and it has a special note for the no-ip.com (noip.com) provider: “Since CC 15.05 require additional package ddns-scripts_no-ip_com to be installed.” And yes, we are on 15.05 now.

So I went to the System/Software page, and under Available packages I cound not find the ddns-scripts_no-ip package, so it couldn’t be installed. But there was an “Update packagelist” button, so I pressed that. After the update, the ddns-scripts_no-ip package IS available to install. I installed it.

I went back to Services/Dynamic DNS, I pressed “Edit” on myddns_ipv4, and the layout of the screen had changed a bit here and there. After trying to start the DDNS service a few times I found in the Log File Viewer that it didn’t work properly yet. I had to fill in my complete hostname (FQDN) in both the “Lookup Hostname” field and the “Domain” field to get it working again. The second one is not intuitive, and if I’m not mistaking it used to be empty, or it had only my domainname in it, without the hostname.

Don’t forget to start your DDNS service again on Services/Dynamic DNS by pressing the Start/Stop button for your specific myddns_ipv* service.

3 Likes