Create LXC container


I want to create LXC container but it’s impossible.
I have test on the luci web interface. The LXC container appear on available container but the process of creation apparantly run indefinitly.

With the CLI method :
root@turris:/srv/lxc# lxc-create -t download -n test
Setting up the GPG keyring
Downloading the image index

Turris_OS       stable  armv7l  default 2020-08-09
Turris_OS       stable  ppc     default 2020-08-09
Alpine  3.10    armv7l  default 2020-08-09
Alpine  3.10    aarch64 default 2020-08-09
Alpine  3.11    armv7l  default 2020-08-09
Alpine  3.11    aarch64 default 2020-08-09
Alpine  Edge    armv7l  default 2020-08-09
Alpine  Edge    aarch64 default 2020-08-09
ArchLinux       latest  armv7l  default 2020-08-09
ArchLinux       latest  aarch64 default 2020-08-09
Debian  Stretch armv7l  default 2020-08-09
Debian  Stretch aarch64 default 2020-08-09
Debian  Buster  armv7l  default 2020-08-09
Debian  Buster  aarch64 default 2020-08-09
Gentoo  stable  armv7l  default 2020-08-09
openSUSE        15.2    armv7l  default 2020-08-09
openSUSE        15.2    aarch64 default 2020-08-09
openSUSE        Tumbleweed      armv7l  default 2020-08-09
openSUSE        Tumbleweed      aarch64 default 2020-08-09
Sabayon 16      armv7l  default 2020-08-09
Ubuntu  Xenial  armv7l  default 2020-08-09
Ubuntu  Xenial  aarch64 default 2020-08-09
Ubuntu  Bionic  armv7l  default 2020-08-09
Ubuntu  Bionic  aarch64 default 2020-08-09
Ubuntu  Focal   armv7l  default 2020-08-09
Ubuntu  Focal   aarch64 default 2020-08-09


Downloading the image index
Downloading the rootfs

After long time :
i have this error

ERROR: Failed to download

It’s on HTTP, on the luci interface i have checked “use HTTPS” and i have all packages required : like ‘wget’, ‘ca-certificates’, ‘gnupg’ and ‘gnupg-utils’.

I have try to download directly and it’s run :

Have you any idea ?



Maybe diference between “armv71(=one)” and armv7l(=character ‘l’)

Not even, i have copy and paste

Thank you for reporting this problem. It will be solved here:

Have you installed the Storage plugin and mounted an external disk? If not please do it and then try to create an LXC container again.

Thank you for your answer. I have added a mSata disk.
How can I add the storage plugin ?

It depends to the TOS version which you use. For example, in 5.1 it can be installed via reForis by checking NAS at Package Management -> Packages. Unfortunately, mounting external disks is not yet contained in reForis and it has to be done in Foris at the Storage page.

On foris page :

On reForis page :

And I have tried to create a container on CLI :
I have the same result
ERROR: Failed to download

Your disk is obviously not mounted. Please check the checkbox beside sda1 and press Format and Set (important: the disk will be formatted to btrfs). When done (see Notifications), your router has to be rebooted.

On Foris interface :

Then on CLI :
I have the same error
ERROR: Failed to download

root@turris:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/mmcblk0p1            7.3G    758.6M      6.5G  10% /
devtmpfs                512.0K         0    512.0K   0% /dev
tmpfs                   512.0K         0    512.0K   0% /sys/fs/cgroup
tmpfs                  1009.8M     29.5M    980.3M   3% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda1               111.8G     24.2M    110.8G   0% /srv

Please send your diagnostics (Diagnostics in Foris or Administration -> Diagnostics in reForis) to our support e-mail ( We will look at it.

It’s sent : turris-rd #1116392

Thank you.

1 Like

Did you know where the issue came from ? I haven’t an answer for my case.

no solution for my issue ?

Hello, please consult the current situation via e-mail to my colleagues which are solving your issue and communicate with you. I’m not participating in it.