Connot start MOX in rescue mode


if I start the mox with pressed button and relaese after first light on it needs a few 10 seconds blinking the both wan port leds and than starts slow 3 s blinking. There is no short blink which shows me it has starts rescue mode 1 and if I press the button again it will not show me any short blinking led. It still continues 3 s slow blingking. If each time if the led off out my 4-port lan extensions blink one time clockwise before front led light ups again.

The router won’t also further booting up without pressed button on power on. It will go in slow blinking mode after few seconds witout blinking any network led like above descibed I tried to start the rescue mode before.

The router has been started before in os 4.0.xbeta but would not upgrade. But an bootlaoder upgrade was possible.
So I tried to upgrade by using rescue mode but now it does not work any more like before.

Any Idea what I can do to finish the upgrade?

So you did an u-boot upgrade? Can you point to the relevant tutorials you followed?

As a general debugging step, please disconnect all Mox modules except for the base module when trying to revive the router.

If you have a 1.8 V UART->USB adapter, this would help a lot as you could see the boot log of the router.

1 Like

This was then trick. I removed firstly all the other modules and could start into rescuemodes so i was able to install the latest firmware by internet connection on Basemodules LAN Port.

1 Like

Glad to hear it helped! So now your Mox runs fine even with all modules connected?

There is now another problem so I will use another threead for that.

I found the mox will not boot up in rescue mode if my sfp module extension D is connected.
If I remove it mox will boot also in rescue mode.
There is no problem with all other extensions I conneted which are pci-e with wifi module + double port usb3 extension + 2 × 4port switch extension.

Please post the complete config of your mox including the module identifiers (e.g. MOX A+B+E+D). Does the configuration pass the validation on ?

Also, do you have an SFP module installed in the SFP cage on module D?

Here is my configuration with an attached 1gb SFP Module on SFP.


I can confirm the issue is been there neigher I attache a sfp module or not.
If I simply attach the the SFP extension to the base module it won’t work.

If I remove the sfp extenison the rescue mode has to been start the rescue mode.

I’ve ordered an usb tty uart module which can be used with 1,8, 2,5, 3,3 and 5V.
So wait a few days so I can say more by adding logs.

If don’t need rescue mode the router starts with sfp extension (and after troubles with the docmented ip adress) i can configure them.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.