Connected to wifi but no internet

Hello,

I configured a new interface for the Wi-Fi and set a zone for the firewall. However, internet connection is not working.

here some configs:

/etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option htmode 'VHT80'
        option channel '48'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option disabled '0'
        option band '5g'
        option country 'xx'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option disabled '0'
        option ssid 'xxx-5'
        option encryption 'psk2+ccmp'
        option wpa_group_rekey '86400'
        option key 'xxx'
        option hidden '1'
        option network 'wifi5'
/etc/config/network
config interface 'wifi5'
        option proto 'static'
        option ipaddr '192.168.42.1'
        option netmask '255.255.255.0'
        option device 'wlan0'
/etc/config/firewall

config defaults
        option forward 'REJECT'
        option synflood_protect '1'
        option input 'REJECT'
        option output 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option network 'lan'
        option forward 'REJECT'
        option family 'ipv4'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include
        option path '/usr/share/firewall/turris'
        option reload '1'

config include
        option path '/etc/firewall.d/with_reload/firewall.include.sh'
        option reload '1'

config include
        option path '/etc/firewall.d/without_reload/firewall.include.sh'
        option reload '0'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule 'turris_wan_6in4_rule'
        option enabled '0'

config include 'bcp38'
        option type 'script'
        option path '/usr/lib/bcp38/run.sh'
        option family 'IPv4'
        option reload '1'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

config zone
        option name 'wifi5'
        option input 'ACCEPT'
        list network 'wifi5'
        option output 'ACCEPT'
        option family 'ipv4'
        option forward 'REJECT'

config forwarding
        option dest 'wan'
        option src 'wifi5'

I’m currently using turris version 6.3.3.

Any idea of what missing or wrong ?

Problem solved.
DNS in previous turris version was reversed in LuCi.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.