Configurazione Omnia 2020 con fibra ILIAD

Ho un problema per quanto riguarda la configurazione dell’Omnia 2020 a tre antenne per quanto riguarda la fibra iliad con net neutrality, sto seguendo la guida sul loro sito, solo che quando vado in system — software se cercho il pacchetto MAP non me lo trova, inoltre mi da degli errori, ho provato a inserire un repository dove sembra sia un pacchetto chiamato map-t ma aggiornando e riavviando il router non lo trova, qualcuno mi può gentilmente aiutare a configurare il modem? inoltre avrei un fritzbox 7590ax da collegarci in cascata ma non ce ne vado in fuori
grazie mille


Cercate di realizzare la vostra in inglese - per l’uniformità del forum
Non sono sicuro di aver capito la domanda - che versione del sistema hai nel tuo router - attuale?

Per quanto riguarda il modem Fritz, non è possibile trovare le risposte cercando nel forum.
Il primo passo fondamentale deve essere quello di aggiornare all’ultima versione di Turris
4 LED: Riflashare il router da un’unità flash Omnia - Turris Documentation

I have version 4.0.1, omnia 2020 model with three antennas. Is it possible to update it or is it the latest compatible version? I tried with the medical kit but it doesn’t work,
Can you connect me to the latest compatible version? Thank you

Modello Turris Omnia
Architettura Processore ARMv7 rev1 (v7l)
Versione del firmware Ramo TurrisOS 4.0.1 80076f9 / LuCI (git-19.281.84184-0b4eebd)
Versione del kernel 4.14.148

Can you describe what happens?

Anyways, the latest version is 6.5.2 released this week. Your software is super-old. Did you turn off autoupdate?

I downloaded this file
put on a USB stick formatted in FAT32 in the main directory (does the stick have to be formatted with some particular name? the tar.gz shouldn’t be extracted right?)
put the flash drive into the USB port on the front of the Omnia and hold down the reset button until 4 orange LEDs light up, after a while it stays on 4 or 5 red LEDs and stays there. I left it for more than 30 minutes but it remains blocked, if I reset it with 2 LEDs the interface restarts but it doesn’t update, is the file I insert into the flash drive correct or am I doing something wrong?
should I disable automatic updates from turris before reflashing?
maybe I have to format the stick in ext4 from linux? or is there another file for rifleshare to use for my omnia it is the wifi5 model not the latest
Thank you

also tried from usb stick in ext4
connected to the front, 5 red LEDs (power 0, 1, 2, 3) remain lit and it remains blocked like this, I don’t know if I’m doing something wrong. I hope you can help me update it

doing some tests I managed to load this img file directly from the luci interface,
Can you send me the updated img file? now foris has disappeared even though I have enough lights but the software section doesn’t work

Oh, definitely don’t do this. This way to upgrade the router is not officially supported.

You should do 4 LED reset. 5 LED is for opening unsecure SSH server.

The flash can be formatted to both FAT32 and ext4, as you like.

If nothing else works, can you at least reset the router to factory defaults? (3 LED reset).

too late, I already did it. have I done any damage? I uploaded this version openwrt-22.03.2-mvebu-cortexa9-cznic_turris-omnia-sysupgrade.img from luci
I installed the maps and now everything works but there is a problem… it won’t let me access the router anymore, I put the password and the wrong one even though I set it right…
How do I remove the password and reset it now?
I’ve now tried to reset it with 2 or 3 LEDs but the password doesn’t remove and foris has disappeared… the internet works but I can’t access the modem without the password, any advice?

if I do the resets with the 3 LEDs now all the LEDs flash blue continuously

Have you tried different formatting of the USB drive?

I tried to format it in fat32 and ext4 by copying the file

directly into the key, it practically freezes on 5 red LEDs and no longer moves forward.
Does the name of the USB drive matter? they shouldn’t create folders on the flash drive or anything else.

There was a change from foris to reforis. What happens if you try to access ?

I manually loaded this firmware from the luci interface:

I set the password and installed map 7, now everything works. Except that I’m sure of the password entered and when entering with it tells me root username and password I enter mine but it doesn’t log in it says it’s wrong… When I entered that firmware does it create another default username? I also tried entering the password and leaving it blank but it won’t log in. I would like to restore it to be able to update it again but upon reflection the firmware remains with the 5 fixed red lights on, doing the reset with 2 and 3 LEDs at a certain point all the blue lights flash and I can no longer restore it. I would like to access the platform again but I don’t know how. I tried formatting in ext4 and fat32 by copying the indicated tar.gz into it but nothing happens…

I fear (but I’m not 100% sure) that by uploading the sysupgrade image, you destroyed the bootloader that was responsible for handling the x-LED reset modes. This would be better clarified by support, try to contact them via email.

If you happen to have a 3.3 V USB-Serial adapter, it would be quite easy to fix the router. Just connect the adapter, boot via serial and flash the latest Omnia medkit.

1 Like

I don’t have the adapter, can anyone confirm if I ruined the bootloader?
If I purchased the latest Omnia 2020 WiFi 6 with 4 antennas, can I still configure it? I just need to install the MAP package,
another question, the grand stream H813 will arrive in a few days, to be able to configure it with the omnia just set the parameters and connect it with the network cable to a LAN port or do you need to do some particular router configuration?

in any case, even before loading the custom firmware from the light interface with the 4 LEDs with USB stick, I was never able to put the medkit on it, it gave 5 fixed red LEDs and remained stuck there in both ext4 and fat32, I tried with 3 sticks different. I don’t understand, also another strange thing, from turisos when I went to updates and clicked on update the system crashed and I had to restore it by holding down the reset to 2 LED mode and it went back to the initial configuration, which no longer happens after I installed the openwrt firmware

To verify the bootloader, log in via the SSH connection and run

cat /dev/mtd0 | grep -i u-boot

to get output similar to this.

root@staging-gw-prg:~# cat /dev/mtd0 | grep -i u-boot
U-Boot SPL 2015.10-rc2 (Feb 25 2021 - 02:37:21)
U-Boot 2019.07 for turris_omnia �

You should be able to go back to stock bootloader and rescue system from the vanilla Openwrt.
You need to download the package turris-omnia-firmware, extract it (it is a tgz file) and transfer the uboot and rescue file to the router.

These two commands should write the correct bootloader and rescue system in the flash memory located on board.

mtd -e uboot /dev/mtd0
mtd -e rescue /dev/mtd1

After this step, perform a factory reset and try to load a medkit from USB drive.

Please note that I haven’t tested this method.

the problem is that I can’t even log in from ssh as it asks me for the password as root user and by entering the one I indicated it doesn’t log in, from the wrong user or pwd, I don’t know how to do it, doing the restore with medkit the 5 red LEDs remain fixed (even before manually loading the firmware from the light interface it did this) I tried with all the 2, 3 and 6 light modes, with 2 and 3 then all the lights flash blue and it stays in the loop like this.
I don’t know if there are other methods to remove the password

I uploaded this firmware,

Is it possible to check if this has a different default password? at this point I’m not sure if I inserted it but I think so and I always put the same one