Close to give up on my Omnias :(

If you Google it you get multiple possible explanations as to why it haplena but I think this reply says it best:

Have you tried what @maurer suggested?

So what card should I buy to get around all of that? The R11e-5HacT? Isn’t that using ath10 as well? Tried to disable ani, so far it’s working ok, but it often has for some days and became unusable again. Will post an update.

Yes - I tried to disable ani. I didn’t get the “excessive missing ACKs” errors but the “deauthenticated due to inactivity” still occurred.

Also for others - keep in mind that the ani change is just temporary. After router reboots the ani is enabled again.

to make it permanent add it to /etc/rc.local , before “exit 0”

Didn’t make a change unfortunately (yes, added the missing > and the value is really set to 0). Still missing ACKs all over the place on the 5GHZ card, and one for the 2.4 GHZ (only use it for IoT devices). I’ll swap out the stock wifi cards tomorrow. Last attempt to throw money and time at the problem. Will report back. Also I haven’t heard anything back from the Turris support for two weeks unfortunately.

So I replaced the stock cards with Mikrotik R11e-5HacT and Mikrotik R11e-2HPnD hoping for a final fix. But no luck. Still the same missing ACKs on the 5Ghz Wifi. Also hardly a surprise, as it’s using the same driver.

What’s worse is that performance is lower now. It peaks at 260Mbit in Iperf, but also fluctuates a lot, at times down to 60 Mbit and stays there.

It seems to me that many performance tweaks posted in this forum are only wishful thinking, which has never seen a benchmark. Larger antennas == better, thicker cables == better, high power wifi cards == better, etc. I couldn’t measure any real world throughput improvement. All of those changes yielded equal or less throughput.


It’s sort of interesting with the R11e-5HacT card. The longer a device is connected to it, the slower throughput becomes. A reconnect restores the initial speed.

I noticed same behavior with different card (Stock card), which Is in my Turris 1.1.

Same behaviour with a Macbook Pro 2015 as client and large File downloads :-/

Have you also tried ‘option disassoc_low_ack 0’ in the wireless UCI file?

Maybe it helps.