Can't pair Android Turris App

How can I pair mobile application on Android with Turris App? Embeded scanner isn’t able to scan QR code.

Another scanner is able to scan it more or less immediately. I can open this link a browser and download .pem file. This workaround doesn’t work.

Any ideas how to pair the application?

Hmmm, or not. I just tried. Zero way to get it square int eh Turris App. So I tried the QR Scanner (another app) and it read it fine (and saw it square). But it then tells me my router is already registered. And I checked the Turris APp and sure enough it’s listed and that was from the initial scan (the rectangular one like in your screenshots above). But alas I can do nothing with it, the apop just has three cycling dots and Connecting… displayed under the header that identifies my router.

So I restarted my phone. Restarted the app. Still connecting …

So I scanned it with QR Scanner and this time accepted its invite to register a new router and so it’s now doing exactly the same thing with MyRouter(1)

Now there is nothing, untoward about my configs, zilch, nix. Router is working, am on-line, phone is on Wifi connected to the router and able to browse the web and more, perfectly connected and fine on-line through the router. Royer has an IP of and phone (a static DHCP lease).

Total waste of time it seems no obvious solution ;-).

Out of interest, how long did it take your phone to connect?

OK, forever and day later, as in literally tens of minutes, it connected! And I see some graphs too small to read and no zoom. Not what I’d call a real useful app :wink: