Can't log in to LuCI in http://

This isn’t really an issue for me, but caused me some confusion, so I thought I should make a note of it here for others. I also don’t know if this is a recent change or it’s been around for a few (many?) releases.

I was interested in getting into my Turris and found I couldn’t log in to the LuCI interface. Foris was fine as was ssh-ing in. Then I noticed I had put http://myrouter rather than https://myrouter in the address bar.

When put in https://myrouter instead, it worked fine.

The query is not accurate. You try it from LAN or from WAN ? If from WAN … you set port forwarding on router ? The addresses you typed are IP or domain ?

This is from my LAN. I mention it since it seemed unexpected.

It’s not really a query either. Just a comment.

I will connect locally HTTP and insecure HTTPS (at 192.168.2.1 is a signpost) . Depending on the browser, connecting to HTTPS warns against an insecure HTTPS connection without a certificate.



a1


a2

Thank you for that write-up @JardaB, but it’s not really relevant to my post. My issue has nothing to do with insecure connections.

Literally, LuCI will not allow me to log in via http://

The page will load and take my password, but then never log me in. It just reloads the page.

this is really a more complicated problem. Have you tried a solution to help rollback schnapps? I would probably send a description of the problem and Diagnostics to support. I would also put aside the image of the current state for future analysis. The easiest way is to repeat the update to 5.2.6.

1 Like

Again thank you for trying to help. However, as I mentioned in my first post

so, I’m not really looking for a solution. I’m just posting here to alert others who may have a similar issue. Perhaps it should be escalated, but I hope most folks would be using https, even on their local network.

If someone else wants to escalate this, please feel free, but I’ve already spent too much time on it.

After today’s few minutes of power failure and router boot, I once failed to log in to Luci in HTTP mode. After confirming the login, the login did not take place, but returned to the login form without an error message. Further attempts have already been successful … Opera browser. I tested Chrome and there was no problem.I backed up the Diagnostics.

In syslog outside the traditional massive Socket error occured '[Errno 2] No such file or directory' still error Failed to parse content

Sep  3 08:18:26 Turris_Omnia foris-controller[5352]: WARNING:foris_controller_backends.collectd:Socket error occured '[Errno 2] No such file or directory'
Sep  3 08:18:28 Turris_Omnia foris-controller[5352]: ERROR:foris_controller_backends.files:Failed to parse content of the file '/proc/mounts'
Sep  3 08:18:28 Turris_Omnia foris-controller[5352]: WARNING:foris_controller_backends.collectd:Socket error occured '[Errno 2] No such file or directory'
Sep  3 08:18:28 Turris_Omnia foris-controller[5352]: ERROR:foris_controller_backends.files:Failed to parse content of the file '/proc/mounts'
Sep  3 08:18:28 Turris_Omnia foris-controller[5352]: ERROR:foris_controller_backends.files:Failed to parse content of the file '/proc/mounts'
Sep  3 08:18:28 Turris_Omnia foris-controller[5352]: ERROR:foris_controller_backends.files:Failed to parse content of the file '/proc/mounts'
Sep  3 08:18:28 Turris_Omnia foris-controller[5352]: ERROR:foris_controller_backends.files:Failed to parse content of the file '/proc/mounts'
Sep  3 08:18:28 Turris_Omnia foris-controller[5352]: ERROR:foris_controller_backends.files:Failed to parse content of the file '/proc/mounts'
Sep  3 08:18:30 Turris_Omnia foris-controller[5352]: WARNING:foris_controller_backends.collectd:Socket error occured '[Errno 2] No such file or directory'
Sep  3 08:18:32 Turris_Omnia foris-controller[5352]: WARNING:foris_controller_backends.collectd:Socket error occured '[Errno 2] No such file or directory'
1 Like

If you login to Foris and navigate to Luci from there (when using http) does it pass thru or not?
Is it same when you are using full URL http://myrouter/cgi-bin/luci/admin ?

Also maybe, just a idea, Lighttpd has “conf.d” where you can find ssl-enable.conf which might handle https correctly, while luci.conf / foris.conf might have some issues with http trafic. And maybe some module is behind that as well (10-redirect.load, 30-openssl.load …in “modules.d” folder).

There is also option for lighttpd to have own error-log…i have, for example …server.errorlog = "/srv/logs/lighttpd_error.log" in /etc/lighttpd/lighttpd.conf .