Can't get DHCP to work on a newly created wifi interface

Hey there,

I’m pulling my hairs out right now, because I’m fiddling for at least 5 hours to get this to work and I can’t tell, where’s the issue and I’d be very glad, if somebody pinpoints me to the issue I’ve produced.

I’m trying to configure a separate wifi (at first, the second thing will be the addition of a lan-port) because I want to separate the internet of shit from the regular lan.
I do have a openhab instance (basically a raspberry pi 3 with debian) which is already connected to the mentioned wifi, and does have a lease. But for some unknown reason I can’t get any other devices to work with this wifi. I’ve tried an Android device and an iPad, both don’t get a lease from the Turris Omnia.
I’d like to mention, that only the openhab instance should have the permission to connect to the internet, no other devices of the “things” network (the name of the wifi, the zone and the interface) is permitted to connect to the internet.

Here’s the dhcp conf:

    config dhcp 'things'
            option interface 'things'
            option start '100'
            option limit '150'
            option dhcpv6 'server'
            option ra 'server'
            option ra_management '1'
            option leasetime '43200'
        list dhcp_option '6,192.168.220.1

firewall conf (above those rules below, there are only the default rules which are created by the omnia):

config rule
        option target 'ACCEPT'
        option src 'things'
        option name 'Allow-things-DHCP-Request'
        option proto 'tcp udp'
        option dest_port '67-68'


config rule
        option target 'ACCEPT'
        option src 'things'
        option name 'Allow-things-DNS-Request'
        option proto 'udp'
        option dest_port '53'

config rule
        option name 'Block-Netaccess'
        option src 'things'
        option dest 'wan'
        option src_ip '!192.168.220.160'
        option target 'REJECT'

and the interface:

config interface 'things'
        option _orig_ifname 'wlan1-4'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.220.1'
        option netmask '255.255.255.0'