Can't connect to Samba share as root user

I have two drives mounted to the Omnia:

  • /mnt/samsung - a USB drive formatted as vfat, shared as samsung
  • /mnt/raid - a RAID drive formatted as btrfs, shared as raid


drwxr-xr-x    1 root     root            44 Jul 31 16:34 raid/
drwxrwxrwx    7 root     root         32768 Dec 31  1969 samsung/

From my OS X machine, I am able to connect to the samsung share as guest and add/remove files.

However, when to connect to the raid share as guest, I get an error that reads

The operation can’t be completed because the original item for “raid” can’t be found.

When I attempt to connect as root, I can’t get past the credential screen:

Shouldn’t the root user’s ssh credentials be valid here?

Do I need to remove the invalid users = root from the /etc/samba/smb.conf.template file?

Perhaps it’s as easy as changing the Samba password?

smbpasswd -a root

Supporting documentation:


# cat /etc/config/samba

config samba
	option workgroup 'WORKGROUP'
	option homes '0'
	option name 'Omnia'
	option description 'Turris Omnia router'

config sambashare
	option name 'raid'
	option path '/mnt/raid'
	option read_only 'no'
	option guest_ok 'yes'
	option users 'root'
	option create_mask '0644'
	option dir_mask '0755'

config sambashare
	option name 'samsung'
	option path '/mnt/samsung'
	option read_only 'no'
	option guest_ok 'yes'


# cat /etc/samba/smb.conf.template
	netbios name = |NAME| 
	display charset = |CHARSET|
	interfaces = |INTERFACES|
	server string = |DESCRIPTION|
	unix charset = |CHARSET|
	workgroup = |WORKGROUP|
	browseable = yes
	deadtime = 30
	domain master = yes
	encrypt passwords = true
	enable core files = no
	guest account = nobody
	guest ok = yes
	invalid users = root
	local master = yes
	load printers = no
	map to guest = Bad User
	max protocol = SMB2
	min receivefile size = 16384
	null passwords = yes
	obey pam restrictions = yes
	os level = 20
	passdb backend = smbpasswd
	preferred master = yes
	printable = no
	security = user
	smb encrypt = disabled
	smb passwd file = /etc/samba/smbpasswd
	syslog = 2
	use sendfile = yes
	writeable = yes

I needed to assign a Samba password to the root:

smbpasswd -a root

Then remove the root user from the invalid users list in the /etc/samba/smb.conf.template file:

# cat /etc/samba/smb.conf.template
#	invalid users = root
1 Like