Cannot get my Omnia to work with SFP

Hi there!

I’ve just recently received my Omnia Router and I want to set it up using my fibre connection to which my ISP’s router was previously connected. But I cannot get it to work.

I am using the same SFP module that was in my old ISP’s router. I have also executed the following command:

ln -sf /boot/armada-385-turris-omnia-sfp /boot/dtbln -sf /boot/ar

And it seems to be supported:

root@turris:~# dmesg | grep -E "(sfp|eth2)"
[    1.594594] mvneta f1034000.ethernet eth2: Using hardware mac address XXXXX
[    8.430422] sfp sfp: Host maximum power 3.0W
[    8.767714] sfp sfp: module OEM              1000BX-S34-10DI  rev 1.0  sn ED606195325      dc 160613
[    8.777092] mvneta f1034000.ethernet eth2: switched to inband/1000base-x link mode
[   14.103189] mvneta f1034000.ethernet eth2: configuring for inband/1000base-x link mode
[ 3250.424002] mvneta f1034000.ethernet eth2: configuring for inband/1000base-x link mode

In the WebUI, it still says eth and not sfp though.

Also these are my ISPs configuration instructions for fibre routers:

English: The WAN interface in the routers configuration menu must be configured to use DHCP Option 60 with the value 100008,0001. VLAN ID must be set to VLAN ID 10.

I cannot find either of these options in the reForis nor LuCI UI.

Thank you for your help connecting my router to the internet!

Best Regards,

To use VLAN ID 10 set your WAN interface to DHCP Client and interface eth2.10 you need to type it in by hand and then in advanced tab you have Vendor Class to send when requesting DHCP and put there what your ISP told you.

You should read more about this vendor options because once I encountered that they had to be hex encoded also try with additional coma , at the begining

Also try to run tcpdump on that eth2.10 interface if you even see some packets flying

Not sure if it matters, but on my VLAN (not directly via SFP module, that is in an externally provided box) setup it looks slightly different (I don’t have a device that is called VLAN like you). See VLAN - Turris Documentation.

Screenshot from 2024-02-12 19-24-34

Not sure if my provider uses the same configuration (VLAN tagging they call it) as yours of course.

It doesnt matter @claudio just created another interface and its in WAN firewall zone supposely correct vlan for his ISP. Then they will just get IP on that interface called VLAN not WAN but at the end it doesnt matter

I’ve tried it with a coma in front, still no success. The tcpdump output is empty:

Will read into the hex encoded vendor though

What kind of SFP module it is? Maybe it has some GUI/CLI to configure some stuff. If I were you I would give the SFP to your ISP and ask them to configure it. There should be router advertisement in tcpdump regardless if you have correct settings so maybe your ISP didn’t configure something or the SFP itself should be configured or ISP needs to provision this SFP.

Despite the fact that it has the form factor “SFP”, the physical IF will be registered as “eth2” within omnia (in openwrt) by OS design & configuration defaults.

I switched back to test my ISPs router using their SFP module (up until now, I had it connected to a dedicated fibre port on their router) which also didn’t work. So I contacted the ISP and asked why I couldn’t use their SFP port either. They said that they updated the fibre connection to a new technology (XGS-PON) providing 10Gbit/s. The SFP module that they ship the router with doesn’t support that but their dedicated fibre port does, which is why I had connected it that way up until now.

And since the tp-link sfp module I bought is 1Gbit/s, I suppose this is causing the issue on the Turris, too.

Do you think buying a 10Gbit/s sfp module that supports XGS-PON could fix the issue?

10Gig module wont work on Omnia as it has “only” 2,5Gbps port. Unless this 10G module can support also 2,5G and the other side which is on ISP device also supports that. And in that case the connection will be negotiated with “limited” speed but should work. But be aware that most of 10Gig modules simply wont work with Omnia. To use full 10Gbps you should consider getting upcoming Omnia Enterprise (not an advertisement).

I’m thinking about getting a XGS-PON bridge that supports 10Gigs such as the Zyxel XGS-PON-Bridge PM7300. I don’t need 10Gigs really, but from what I’ve understood from my ISP, it won’t work with a 1Gig module.
So with the bridge I could just attach the LAN port than and use 1.5Gigs…

Lan ports on Omnia are 1Gbps😋 If the switch supports 2,5Gbps on its LAN ports you could use Turris SFP module with ethernet connector and use what Omnia can do.

Well, if you already have a GPON module, ask them politely whether they would provision you via GPON instead of XGS-PON, assuming you are happy enough with 1 Gbps… now not sure about swisscom… Or switch to Init/ which IIRC allow FTTH via PtP and might still offer 1 Gbps (look at their fiber7 offerings)

Could I not go from the Bridge RJ45 out straight into the WAN ethernet port of the Omnia? (instead of having to buy the SFP RJ45 adapter?)

Okay, so I finally got it to work! For anyone interested / facing the same issue:

  • Purchased a XGS-PON compatible router / bridge (Zyxel PM7300)

  • Connected the fibre outlet straight into the PON port of the Zyxel PM7300

  • Accessed the Zyxel web interface (after resolving some usb ethernet adapter issues) and configured the WAN interface to use VLAN ID 10 (802.1q)

  • The LEDs on the Zyxel were all green at this point, yet there was no connectivity to the internet

  • I plugged in my Turris Omnia (Zyxel 10GbE → WAN port of Omnia)

  • I re-configured the VLAN Interface (as shown above) using the correct VLAN Vendor Class (from my ISP, as mentioned before)

  • It worked! (I did have to tweak some things like DNS forwarding, etc. for it to work properly, but that’s all I did)

Thank you @AreYouLoco and everyone else!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.