Cannot get my Omnia to work with SFP

Hi there!

I’ve just recently received my Omnia Router and I want to set it up using my fibre connection to which my ISP’s router was previously connected. But I cannot get it to work.

I am using the same SFP module that was in my old ISP’s router. I have also executed the following command:

ln -sf /boot/armada-385-turris-omnia-sfp /boot/dtbln -sf /boot/ar

And it seems to be supported:

root@turris:~# dmesg | grep -E "(sfp|eth2)"
[    1.594594] mvneta f1034000.ethernet eth2: Using hardware mac address d8:58:d7:02:00:21
[    8.430422] sfp sfp: Host maximum power 3.0W
[    8.767714] sfp sfp: module OEM              1000BX-S34-10DI  rev 1.0  sn ED606195325      dc 160613
[    8.777092] mvneta f1034000.ethernet eth2: switched to inband/1000base-x link mode
[   14.103189] mvneta f1034000.ethernet eth2: configuring for inband/1000base-x link mode
[ 3250.424002] mvneta f1034000.ethernet eth2: configuring for inband/1000base-x link mode

In the WebUI, it still says eth and not sfp though.

Also these are my ISPs configuration instructions for fibre routers:

English: The WAN interface in the routers configuration menu must be configured to use DHCP Option 60 with the value 100008,0001. VLAN ID must be set to VLAN ID 10.

I cannot find either of these options in the reForis nor LuCI UI.

Thank you for your help connecting my router to the internet!

Best Regards,
Claudio

To use VLAN ID 10 set your WAN interface to DHCP Client and interface eth2.10 you need to type it in by hand and then in advanced tab you have Vendor Class to send when requesting DHCP and put there what your ISP told you.

Thank you for your response.

I’ve created a new VLAN interface now like this:

But there is still no internet connection. What am I doing wrong?

You should read more about this vendor options because once I encountered that they had to be hex encoded also try with additional coma , at the begining

Also try to run tcpdump on that eth2.10 interface if you even see some packets flying

Not sure if it matters, but on my VLAN (not directly via SFP module, that is in an externally provided box) setup it looks slightly different (I don’t have a device that is called VLAN like you). See VLAN - Turris Documentation.

Screenshot from 2024-02-12 19-24-34

Not sure if my provider uses the same configuration (VLAN tagging they call it) as yours of course.

It doesnt matter @claudio just created another interface and its in WAN firewall zone supposely correct vlan for his ISP. Then they will just get IP on that interface called VLAN not WAN but at the end it doesnt matter

I’ve tried it with a coma in front, still no success. The tcpdump output is empty:

Will read into the hex encoded vendor though

What kind of SFP module it is? Maybe it has some GUI/CLI to configure some stuff. If I were you I would give the SFP to your ISP and ask them to configure it. There should be router advertisement in tcpdump regardless if you have correct settings so maybe your ISP didn’t configure something or the SFP itself should be configured or ISP needs to provision this SFP.

Despite the fact that it has the form factor “SFP”, the physical IF will be registered as “eth2” within omnia (in openwrt) by OS design & configuration defaults.