Cannot connect to WLAN (5ghz and 2.4ghz) since 3.9.2


after the upgrade from 3.9.1 to 3.9.2 I can’t connect with any client to my wlan.
I tried it with my laptop and my smrtphone. They see the wlan but can’t connect to that.

In luci I can see the device under connected wlan devices. This problem is on both networks, 5ghz and 2.4 ghz.

I restart the router and updated the package lists and restart the wlan over luci.

Can anybody pls help me to get my wlan working again?

Try to usw the Manuel config for the IP adresses and not usw DHCP by my Turris Omnia the DHCP Funktion broke with this update and i Bad the same issue. At the Moment i am waiting for the support.
But their are Mord problems than only the DHCP Funktion. For example the msata isn’t mounting anymore and it is also not recognised.
And you habe to an other DNS Server for example because this Funktion is also not Wirkung anymore

The previous update also broke DHCP and created multiple new problems, which took me weeks to diagnose and repair. A full 30 days passed after contacting support before their first response came, and it was a template message asking me to consult the manual.

I hope you have a ‘Plan B’, because the router, updates, and support are completely unreliable and this is not a new situation. The router is great when everything works, but once something goes wrong it stays wrong for a long time and you are completely on your own to solve it, and to undo the damage caused by ‘updates’.

Thanks for your comment, that are realy Bad news habe you experience with the lede of open wrt Projekt in this forum, do they make thinks better?

My plan b is to reset the Router and make the update before Konfiguration. Maybe than it will work Luke it shuld

If you reset the router it will just update and break connectivity again. I kept my old router that I used before purchasing the Omnia, and I use that for a week or two until all the problems caused by updates are resolved (or at least there are easy to follow workarounds posted here).

Think of the Omnia as an experimental race car. Great fun to use when it works and great performance, but completely unreliable, and you need a second car available to drive that actually works when you need it.

thanks for tthat information do you know how to set an dns server via ssh cause the turris could even use the dns via luci so wouldn’t be possible to update

Setting DNS via LuCI has no effect, so do not bother trying to use that. I don’t know how to manually set DNS on the Omnia using SSH (probably the answer is already posted here in another thread?) but you can also try setting DNS on your device(s) so they bypass the problem with the Omnia. Any desktop OS should let you do this, but it may not be possible on mobile devices.

thanks yes my pc has set an other dns but i thaugt that i have to make it for the turris itself bekause when i want to update manually it couldn’t resolf the update pages so i am hoping to find a solution

WLAN speed was very slow with 3.9.2 (~500Kbps) on 5GHz. Opening web pages took a long time.

Downgrading to 3.9.1 following (I had to use http instead of https) restored normal speed and responsiveness.

Thanks, but don’t worked for me. I created the archive.lua with the path to turris 3.9.1.

But this error apear:
line not found
line not found
line not found
unreachable: Couldn’t resolve host '
Alarm clock
Working on message: 1516191465-3443
cat: can’t open ‘/tmp/user_notify/1516191465-3443/message_de’: No such file or directory
Working on message: 1516201947-10910
cat: can’t open ‘/tmp/user_notify/1516201947-10910/message_de’: No such file or directory
Working on message: 1516220321-8030
cat: can’t open ‘/tmp/user_notify/1516220321-8030/message_de’: No such file or directory
Working on message: 1516223005-16879
cat: can’t open ‘/tmp/user_notify/1516223005-16879/message_de’: No such file or directory
Working on message: 1516223193-18088
cat: can’t open ‘/tmp/user_notify/1516223193-18088/message_de’: No such file or directory
Working on message: 1516223318-18548
cat: can’t open ‘/tmp/user_notify/1516223318-18548/message_de’: No such file or directory
msmtp: cannot locate host Try again
msmtp: could not send mail (account default from /tmp/user_notify/.locked/msmtp.cfg.18559)

How can I tell him to use my archive.lua?

Have you tried to disable resolver and kresd?

please don’t recommend other things that we don’t support or we don’t test them internally when we’re releasing a new version of Turris OS. When you’re using something, which we don’t support and you don’t want that something happens to other, too. You can tell us when we’re releasing RC branches for public testing.

Right now we officially support (and provide support) for kresd as DNS resolver on Turris Omnia.

If you use a different configuration than we then it can happen that with next update we’ll overwrite some files, which are not editable by a user. So it could happen that you don’t have working internet connection because you use dnsmasq or some other DNS resolver.
For example if you don’t disable kresd (and you didn’t uninstall it) then at the next startup it will start and it will start also dnsmasq, which you want to use and you configured it, but it will tell you that there is already application which already listen on port 53, which kresd and dnsmasq use.

We’re working on a solution, which will tell you, which file you edited and if it will be replace with next update or not.

I’m really sorry that we responded to you so late, but next time if this happens, please tell me or just ping us in the ticket. I checked it, but you didn’t respond to us, that’s why we closed a ticket. We thought that you solve your issue, but I apologize for that, but we couldn’t tell you what’s wrong without sending diagnostics.
I looked and you’re the only one with this issue. Did you contact your ISP if he didn’t change something and he didn’t tell you?

I’m really sorry that this happens to you.
Please, can we look at your issue on our support? Would you be so kind and send us diagnostics to our email
Don’t forget that diagnostics contain sensitive and important information and they shouldn’t be upload to any public cloud or file hosting. Attach them to email, which you’re sending or you can attach them to ticket system, which we use.

from what I know we didn’t do any chance to wireless.
Can we look, what is happening in your case?
Please send us diagnostics and we’ll help you.

Thanks for following up, and I confirm my ISP was able to resolve the issue. Because so much time had passed between my support request and the support response, I did not think a response was necessary (users would never accept a month-long internet outage and it’s safe to assume they would have fixed the problem or replaced the device by then), however I should have closed the ticket - apologies.

Would you be willing to consider a feature request? When I update my desktop or servers, those updates never break my customisations. I either get a warning from the updater asking me to resolve a conflict, or the file(s) being replaced contain a comment at the top instructing you how to properly make customisations by placing a new file somewhere so updates won’t overwrite your edits.

The Omnia does not do this, user disabled features are re-enabled without asking for confirmation and user customisations overwritten, leaving us with broken configurations and no internet connection. The safe default is for the update to stop or fail, and alert the user (with a meaningful error message) that they must resolve the issue.

I do understand that the Omnia team cannot be expected to support all use-cases, but I think the updating process could be improved.

thank you for your message.

We appreciate every feedback even feature requests.
We know about it and we have plan to do something with it. :slight_smile:

Right now you can check it manually with command pkg_check

Does documentation for this new command exist? I tried a search and did not find any meaningful results. I just tested it and I see this:

root@turris:~# pkg_check
 * Changes found in package dnssec-rootkey:
   - /etc/root.keys: FAILED

 * Changes found in package luci-base:
   - /etc/config/ucitrack: FAILED
   - /etc/config/luci: FAILED

 * Changes found in package pciutils:
   - /usr/share/pci.ids.gz: FAILED

Some packages contain changed files!
Maybe something worth looking into?
Here is the list of packages and changed files:

 - dnssec-rootkey: /etc/root.keys
 - luci-base: /etc/config/ucitrack
 - luci-base: /etc/config/luci
 - pciutils: /usr/share/pci.ids.gz

It is good to hear something is being worked on but I don’t know how to interpret these results or if my router will leave me without an internet connection the next time it updates. Those files all look fine to me - is further action required?

Hi, I got simillar list with more files :wink: Does it mean that those are files which I changed (comparing with your template, for example)?

Is it possible now to disable AND remove kresd? In the 3.7.x series it was not, the updater Lua scripts always installed it back.

I am using a combination of DNSmasq and Unbound, which I have been using on my previous OpenWRT router since maybe from 2010. So I don’t need kresd at all and if possible, I would like to remove the cruft from my router.

yes. It is possible, but keep in mind that this way is not supported and it might break in future.
See our documentation.