Br-lan static protocol no dynamic IPv6-prefix behind Fritz!Box


the Turris Onmia is configured as an ethernet switch and one-armed router behind a Fritz!Box 7490 (Fritz!OS 7.01). br-lan is configured with static protocol and Use builtin IPv6-management enabled. br-lan gets a fe80::/64 address but unlike all other hosts no public dynamic 2003::/64 prefix.

What do I have to configure?

See here, I believe you are in the same situation:

Edit: You configured ipv4 static, I am not sure if this sets ipv6 to static, too. dhcpv6 is needed for prefix delegation. Maybe someone else can answear this. What definitly should work is to set a static ipv4-dhcp lease on your Fritzbox for your TO and then set complete interface-config on TO to dhcp.

EDIT: I just saw that you don’t have a typical WAN/LAN setup. In that case you can create an additional interface in LUCI named eg. “LAN6” with protocol “DHCPv6 client” and as physical interface a new userdefined interface named “@lan

I guess, with ‘one-armed router’ you mean being a host computer. In that case, please, continue there…

For surfing the internet with a host you need no adaption.

Prefix Delegation is an issue. And it works well with Turris. If you adjust the settings in the FritzBox.
Be aware you use 2x DHCPv6 side by side - frequent source for trouble.

I wrote a cheat sheet for Prefix Delegation here:

Hope it helps.