Both wifi interfaces are always "Unassigned"

I tried every possible combination of Wi-Fi 1 and Wi-Fi 2 setup and any of them every time is “Unassigned” so I cannot acces lan and/or internet from the connected devices. What can be causing this? Another smaller issue I have is that WiFi is off, when I select the auto band.

The problems started all by themselves, or it is from the beginning. Changing some network settings manually didn’t work ?? First help for wifi problem is to do a reset in reForis Network settings - Wifi ucela at the bottom of the page

From the beginning. I tried to reset wifi setting about 6-10 times, and even did a full factory reset going through the guide again.

Arr you talking about reforis or luci? If they’re unassigned in reforis, it’s not necessarily a problem. Some of my routers also report the assignment wrong in reforis, but it actually works and luci shows a proper config.

I was primarily checking reforis as I thought it’s newer and therefore should be better. But I checked luci and played around a bit and got the following screenshots:

I think “not associated” in luci means just that there is no connected client.

Well, I’m not sure, what it means, but still there is no internet, if I connect a device to it.
I tried few things again, and found out, that I can get to the internet, if I asociate the interface with a guest network, so at least it’s not a problem on the WAN side, but when I swith it to LAN - once again - I can’t reach anything, not even the router.

So I tried factory reset and config using JSON on a USB drive - the device booted OK, but when I connect to the TurrisConfigWifi I get the following:

% ifconfig en0
	ether bc:d0:74:0c:db:9e
	inet6 fe80::185e:1f91:c41c:a5d%en0 prefixlen 64 secured scopeid 0xf
	inet netmask 0xffffff00 broadcast
	inet6 fdd4:acd2:3ee8:0:189b:38b4:2df7:1dbf prefixlen 64 autoconf secured
	nd6 options=201<PERFORMNUD,DAD>
	media: autoselect
	status: active

% ping
PING ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
--- ping statistics ---
4 packets transmitted, 0 packets received, 100.0% packet loss

% curl
curl: (7) Failed to connect to port 80 after 4 ms: Couldn't connect to server

Am I doing anything wrong?

Here’s an update…

When I connect to the “main” wifi, I get assigned ip but I cannot access the router on because it’s at, which I can access. But I also cannot access the internet.
When I switch to the “guest” wifi, I get assigned, I can no longer access the router on, but I CAN access the internet.

Does it make sense to any of you?

This really looks the guest network DHCP server somehow also runs on the wrong br-lan interface. Normally, guest network uses a different DHCP range than the internal one.

Can you try disabling guest network in reforis?

Well, I didn’t touch the DHCP settings - it’s all fresh after a factory reset.

This topic was automatically closed after 60 days. New replies are no longer allowed.