Boinc - volunteer computing

Thinking what to do with my most idle Omnia, I thought it would be good to use it for BOINC project … Anyhow, trying to install it in Ubuntu container, I got following errors :frowning:

root@LXC_NAME:~# apt-get install https://boinc.berkeley.edu/dl/boinc_7.2.42_i686-pc-linux-gnu.sh
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package https://boinc.berkeley.edu/dl
E: Couldn’t find any package by glob 'https://boinc.berkeley.edu/dl
E: Couldn’t find any package by regex ‘https://boinc.berkeley.edu/dl

What can I do to make it ready? any hints? TIA :wink:

First, judging by the i686 substring, I don’t think that link will run on Omnia.

Depends on how it’s linked. Since 3.8.6 the Omnia can run statically linked x86 binaries. But it’s never going to run fast…

An option would be compiling it from sources:
https://boinc.berkeley.edu/trac/wiki/SourceCodeGit

But no guarantees… Compiling could be a problem.

I’m interested in the same thing, but I still have another problem. Projects in which I’m involved do not have Linux on ARM: https://boinc.berkeley.edu/projects.php . So I have about two options. Trying to somehow go around Android under LXC. Or use Linux on Intel (Version for x86) on QEMU.

But anyway these guides could help:


Omnia + x86 BOINC :sunglasses:

Peculiarly, repeated attempt to install boinc client was without any problem now :wink: Boinc is running on ARM! Thanks to above mentioned docs, I was able to make some progress - but, in the end, I got some errors, like

dir_open: Could not open directory ‘slots’ from ‘/usr/bin’.
This computer is not attached to any projects

and, repeating many times

dir_open: Could not open directory ‘/dev/input’ from ‘/usr/bin’.
dir_open: Could not open directory ‘/dev/input/mice’ from ‘/usr/bin’.

I’m affraid that creating those directories would’nt help. Moreover, I wonder why there is error “This computer is not attached to any projects” when I successfully attached it to my World Community Grid account :frowning:

I’ll investigate more later.

This is one of many examples. You should try one of the projects with the icon ARM powered: https://boinc.berkeley.edu/projects.php . But anyway thanks for the basic research. I’m still dealing with disk space and maybe cooling before I go into it.

Edit: Sry TMI. I have a NAS. I have an idea how to improve the cooling. BOINC may need it. I just wanted to say I won’t share my experiences yet, because now is my priority to organize my data.

As to disk space, easy solution is USB. I added 2 flash USB to my Omnia - one for logs, second for containers. As to cooling, there was discussion long time ago about it, mainly in czech thread… I’ll translate it for you, if it does help.

It wasn’t needed to compile boinc from sources, fortunately. As I learned later, there is already boinc included in Ubuntu container :wink: thus it was as simple as running install boinc in it. But I’m still struggling making boinc to compute.

Unfortunately I blindly attached to my World Community Grid account, which I’m using on my desktop :frowning: Only later I paid attention to projects details like ARM icon :frowning: which costed me quite a lot of time.
But even after attaching to an ARM project (LHC@home), there were still problems - boinc tried to attach to World Community Grid project (I had to remove all projects except LHC from all_projects_list.xml), didn’t recognize some XML tags in config file cc_config.xml (which I copied [and edited] from http://boinc.berkeley.edu/wiki/Client_configuration page), can’t open slots, /dev/input and /dev/input/mice directories (from /var/lib/boinc-client)…
Requesting state and project information, there is LHC@home URL and some more information, but no jobs, no elapsed time, no applications, no tasks (but not empty time stats!).
I’ll try to ask boinc community if they can advice me.

I’m so sorry it wasn’t clear. I used Power architecture before, so I have experience with this. I also use the Raspberry Pi Desktop on X86_64. It screamed that the project may won’t work. But it’s running. With the BOINC community it’s a great idea, maybe it’ll get TO on the map of another interesting project. On the World Community Grid forum there is some thread about rpi3 https://www.worldcommunitygrid.org/forums/wcg/viewthread_thread,39145_offset,20#539212
But, it is question on someone from the team @mpetracek, if we can use the *.APK directly on TO?

My error, my omission! :frowning: options tags should be surrounded by <options> and </options> ! Ouch!

Thought to give up, for persisting errors :frowning: Fortunately found contact to debian boinc development group :slight_smile: Got some advices, avaiting more. There is still hope!

1 Like

I made some progress, with help of Debian Boinc maintaner Gianfranco Costamagna (thanks a lot!!!). But, there maybe problems as to firewall setting :frowning: Boinc client is communicating on port 31416. I tried to set a firewall rule to allow this connection (see below), but I’m affraid it does not work. Could please anybody more knowlidgeable help? TIA - UPDATE, see below.

Firewall - Traffic Rules - boincLAN
Rule is enabled
Name - boincLAN
Restrict to address family - IPv4 and IPv6
Protocol - TCP+UDP
Match ICMP type - any
Source zone - lan:
Source MAC address - any
Source address - any
Source port - 31416
Destination zone - lan:
Destination address - any
Destination port - 31416
Action - accept
Extra arguments - empty
Rest of Firewall - Traffic Rules form is empty,
supposing it’ll apply any time.

Update - communication problem cleared with help of @protree in separate topic. TL;DR: Boinc in Ubuntu container on Omnia router is accessible from Windows PC on the same LAN; it is even accessible from another Ubuntu PC on port 31416. Unfortunately Boinc Manager running on Windows PC stil can’t connect to Boinc client on Omnia router - I have to investigate more.

  1. buy expensive overpowered router
  2. overload it with useless applications so it is underpowered again
  3. profit???

Wrong :frowning: I bought Omnia for I liked it, wanted to support the project, and first and foremost I wanted secure, supported router.

Even if I agree that it is expensive and overpowered, especially in such a case it is useful to offer part of its power to something meaningful, which Boinc is (have a look).

Fortunately, computing for Boinc can be set in such a way, that it’ll take only set proportion of system resources, thus it could be tuned to the state the router not became underpowered.

2 Likes

Have you tried to install Boinc Manager. I will connect from another computer to my Debian without a problem. Just enter the IP address from are you connecting to: “remote_hosts.cfg” and the password to „gui_rpc_auth.cfg" https://boinc.berkeley.edu/wiki/Controlling_BOINC_remotely

Thanks for your hints, I already know it.

After some experimenting I found that I have to set both IP address (of computer, on which is Boinc Manager running) and password, to be able to connect to Boinc client on Omnia (documentation was not clear in this)…

Then there were difficulties finding project which will run on Omnia - I tried some of them, but some were not able to connect to project at all, some connected to project but didn’t got tasks; in the end no one was able to compute any task, even though I played with settings of preferences… I got quite tired and down so I interrupted experimenting for a while :frowning:.

By “I will connect from another computer to my Debian” do you mean Debian on another PC or Debian in container on Omnia? If the later is the case, could you kindly specify which project do you use and how you set computing properties? I’d check and try again :wink:

Just Debian in a container on another PC.