Avahi - conflict files


#1

I have a similar problem

##### Oznámení o chybách #####
Updater failed: 

[string "transaction"]:317: [string "transaction"]:146: Collisions:

• /usr/sbin/avahi-daemon: avahi-dbus-daemon (existing-file), avahi-nodbus-daemon (new-file)

• /etc/init.d/avahi-daemon: avahi-dbus-daemon (existing-file), avahi-nodbus-daemon (new-file)

• /usr/lib/libavahi-common.so.3: libavahi-dbus-support (existing-file), libavahi-nodbus-support (new-file)

• /usr/lib/libavahi-common.so.3.5.3: libavahi-dbus-support (existing-file), libavahi-nodbus-support (new-file)

• /usr/lib/libavahi-core.so.7.0.2: libavahi-dbus-support (existing-file), libavahi-nodbus-support (new-file)

• /usr/lib/libavahi-core.so.7: libavahi-dbus-support (existing-file), libavahi-nodbus-support (new-file)

• /etc/avahi/avahi-daemon.conf: avahi-dbus-daemon (existing-file), avahi-nodbus-daemon (new-file)

Update fails with file conflict
#2

You have to decide whether you want dbus version of avahi or non-dbus one. You can’t have both.


#3

But I do not have both versions.

root@turris:~# opkg list-installed | grep avahi
avahi-autoipd - 0.6.31-13
avahi-dbus-daemon - 0.6.31-13
avahi-dnsconfd - 0.6.31-13
libavahi-client - 0.6.31-13
libavahi-dbus-support - 0.6.31-13
root@turris:~#

#4
  1. I uninstalled packages with a parameter --force-depends.
  2. Updater ran without errors.
  3. I installed avahi - version NODBUS.
  4. All is OK