After restart, DHCP refuses to assign IPv4 addresses


#1

I’m running the latest 3.8.5 and after restarting, the router will only assign IPv6 addresses to all devices on my LAN. Now none of these devices have any internet connectivity, despite being previously assigned static IPv4 addresses.

I’m unable to connect to the Omnia to troubleshoot or administer it, all I can try is resetting it and after several attempts IPv4 connectivity still fails. What are my options now please?

Two Ubuntu machines show this connection info, and an Android device simply times out after trying to connect to WiFi after a while. All were working perfectly just before the restart of the Omnia.

EDIT: Similar problems here (“Client not receiving a new IPv4 address after router reboot”) and here (“DHCP/Network up seems to be flaky”) and the suggestions to restart, switch Ethernet ports, or restart the network manager on the connected devices does not resolve the bug.


#2

IPv6 address from fc00::/7 isn’t really usable either (i.e. only within LAN).


#3

Nothing on the router LAN is usable right now, route -n produces no output. I’m using a tethered mobile for connectivity and hoping to resolve this soon.

I just tried the “Rollback to latest snapshot” reset option and after restarting it’s still broken.


#4

You can ssh to your router with ipv6 address

on your PC try

ip -6 route|grep via
ssh -6 root@hex:hex:hex%enp0s31f6 

It seems like dnsmasq isn’t running, usually that is case when it tries to listen on port 53 which is occupied with kresd/unbound.

Check on router

uci show dhcp.@dnsmasq[0].port=‘0’

or set it with command

uci set dhcp.@dnsmasq[0].port='0’
uci commit dhcp
/etc/init.d/dnsmasq restart


#5

Thanks, I am able to ssh to the router using your instructions however this didn’t resolve the problem yet.

uci show dhcp.@dnsmasq[0].port='0' returns dhcp.cfg02411c.port='53', so it appears you are correct that it is using port 53.

Next I tried uci set dhcp.@dnsmasq[0].port='0' && uci commit dhcp && /etc/init .d/dnsmasq restart, which returned the following error message:

udhcpc: started, v1.25.1
udhcpc: sending discover
udhcpc: no lease, failing

Is there a way to troubleshoot this further, and to prevent this from happening again?

I note I am using Pi-hole in an lxc container on the Omnia as my DNS server.


#6

Yes I am aware this is a year old…

with the 3.11 update I have this exact same issue and cannot get past the

udhcpc: no lease, failing

message. Running a very similar setup, and only getting IPV6 addresses which are less then usefull.
How do I get my connection back up and running???


#7

If I recall correctly, updating unexpectedly re-enables the Knot DNS resolver which broke my Pi-hole setup completely. I had to re-flash the router, starting all over again, and using this to permanently disable Knot in future updates:
echo 'Uninstall("knot-resolver", { priority = 60 })' >> /etc/updater/conf.d/user.lua