AdBlock port forwarding

After problems with AdBlock and his reinstalation i see new port forwarding.
Is that right? In older versions of AdBlock were mentioned somewhere only about forward port 53 (I do not know whether it was correct).

AdBlock is not a DNS server, so these rules won’t help you. If you want some to be blocked and some don’t, you need to do baypas you don’t want to block.

Rule records were created when installing AdBlock - not manually !

Yes you are right. It makes this choice:

When i check or un-check option “Redirect all DNS queries from ‘lan’ zone to the local resolver” - setup does not affect firewall redirects setting 53, 853 and 5353.

The conclusion is that the above mentioned redirects are needed for the proper function of AdBlock ?

Typically not AFAIK. So far it seems normal to use local DNS by default, so in those cases it shouldn’t make a difference. I personally think this “interception” isn’t worth it, especially for ad-blocking.

BTW, apps can always make it much harder to intercept DNS, especially with the current trends, e.g. Firefox announced ( article) they will “tunnel” DNS through HTTPS by default (at least in some regions).

I’ve already understood it, you’re right, there is a bug in Adblock - it does not remove the firewall rules - the bug.

No, this option is disabled by default and only useful for rare cases, where connected devices use hardcoded google dns server as resolver (e.g. older android devices).


which adblock version? Not reproducible with current version - please provide the output of /etc/init.d/adblock status

Oh, sorry, I reinstalled AdBlock (luci-app-adblock and adblock) and I can’t reproduce the error - I use TOS4. Tested version: 3.5.5-3. Maybe help @JardaB

I am on AdBlock 3.5.1-1 version

While we’re at it - I’m reporting a bad version identification: package: 3.5.5-3, in /usr/bin/ 3.5.5-2 and LuCI too.
Same identification in OpenWrt repository.

That’s only a cosmetic issue of this release - just ignore it.

I guess I understand how it works. If the status is: “Adblock Status: running”, then it must wait until the status is: “Adblock Status: enabled”, then the option can be pressed again and saved and used. If you do it too quickly and don’t wait, the choice will not be made. It would be good if the status is running so that you cannot press “Save and Apply”.
This is the solution for me.

In the past, if I’m not mistaken, the adblock installation added port forward rules for ports 53, 853 and 5353. I have now discovered that although I have adblock installed these rules are not there.

I have a my bad memory, is this a bug or is it Ok ?

Aha, the new setting is disabled in the default, it has to be done manually ?