AdBlock on Omnia TOS 5

I first mention the clean installation of TOS 5 …but so far I have not been able to activate the DNS report function, is the error on my side or is it a property ?


*** Package tcpdump-mini and tcpdump are instalated.

*** When you press the DNS report - Refresh button, the page loads a very long (timeout) view, but loads nothing

Under “Advanced Report Settings”, I believe you also need to set “Report Interface” to br-lan and set “Report Directory”. You can set it to “/tmp” somewhere, but if you have persistent storage, you’ll get more history and it will not be cleared after reboot.

I didn’t get any data until I set the “Report Directory” for sure.

Yes , I had the wrong interface set up. But editing the “Report Directory” field is not possible in Luci … the field is grayed out. Is probably need to edit the /etc/init.d/adblock file, but there is a folder /tmp/ in multiple places in code and I can’t figure out which of the values I should edit - maybe all.

After router restart "DNS Report " working. Now the working directory :slight_smile:

In /tmp/ folder are this file

EDIT 18:29: edit file /etc/init.d/adblock I failed and had to reinstall AdBlock

What did you mean by that? In TOS 5.3 (hbl branch) I can’t see any error, e.g

Please also note the tab headline - changes on this tab need an adblock (or a router ;-)) restart.

Turris OS version 5.1.10
Turris OS branch HBS
Kernel version 4.14.222

All field for folder setup are non editable - grey

Bez názvu2

Bez názvu 3

It’s nothing critical, I’ll wait for the functional version

Did you select at least one input field and did you try to input a valid path? What you’ve marked is the grey default value (a HTML placeholder), just overwrite this … it’s standard in LuCI.

That hasn’t happened to me in a long time :slight_smile: I’m not allowed to leave the house today and do nothing.

I tried to delete the default text !!! And since it couldn’t be deleted, I didn’t start writing anything !!!

Sometimes it is necessary to lead the weak-minded by the hand … yes, I’ve already set up it.

Thank you, good man.

1 Like

You can also try to edit the “/etc/config/adblock” file directly.

Here’s what mine looks like:

config adblock 'global'
	option adb_enabled '1'
	option adb_debug '0'
	option adb_forcedns '0'
	option adb_safesearch '0'
	option adb_dnsfilereset '0'
	option adb_mail '0'
	option adb_backup '1'
	option adb_maxqueue '4'
	option adb_dns 'kresd'
	option adb_fetchutil 'curl'
	option adb_backupdir '/mnt/sda1/backup/adblock'
	option adb_reportdir '/mnt/sda1/var/log/adblock'
	option adb_repiface 'br-lan'
	option adb_report '1'
	list adb_sources ...

If you can edit that, then you can set what you like.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.