AdBlock and Google advertising

I use AdBlock on version 3.11.22. For more than a year I have observed that mainly advertising Google mainly **, push sometime through the blocking. If you immediately command /etc/init.d/adblock reload , it is quiet again for a while.

Somehow I do not know what could be the cause, and by extension how to solve the wrong function

I don’t think adblock on OpenWRT sets up a cron job by default to refresh itself.

Since you need it to update periodically, you’ll want to put the file somewhere that it isn’t writing to the emmc. I’ve got mine on my SSD (/etc/kresd is a link to my SSD), but you could put it in tmp too, which would probably be fine.

Then, add a crontab entry for it. I update once a week, which seems to be pretty good. Here’s my crontab entry:

5 2 * * 3 /etc/init.d/adblock reload

You can use the GUI and hit “Refresh Timer…” button and fill in the fields.

I apologize if you already have this set up, but this is something I was caught by when I first set it up.

I restart my router one for week and AdBlock every 6 hours. But it is not enough. I’d rather hear the system solution.

This sounds like thread for @dibdot (adblock upstream, I think).

Do you use Chrome browser?
In the last versions, Chrome bypasses default DNS.

I believe they avoid automatically switching to a different DNS provider. (i.e. they switch to DoH of the same provider, if available)

So far, I have used Opera browser with DNS-over-HTTPS settings ON. I’ll see how the change of settings takes effect. In Foris DNS without forwarding.


If your browser uses DoH to Cloudflare instead of Turris’ DNS, I don’t get how you intend the adblock package to work.

  • This setting was due to errors and unavailability of some web pages, followed by a browser Opera instruction to set up DNS-over-HTTPS !!!
  • Now I have set forward to DNS servers CZ.NIC and DNS-over-HTTPS in my browser I have turned off. In the first attempts I do not have problems loading pages. I’ll see what happens to ads.

In Adblock, you can check “Force Local DNS”.
That option will force all DNS requests to the router.

If you use DNS-over-HTTPS in your browser, you are going to bypass the Adblock.

Yes, here is all my AdBlock settings … I need a moment to observe the behavior in the new settings … the problem manifests itself only occasionally.

hi there, i tried this setting in ( latest 5.x os omnia ) adblock 4.0.7, but i assume you have to also set your DNS in reforis to local? Since just setting 'force local dns 'in adblock gave a error/no go here?


edit 2, on the mox it has issues…Hmmm not sure since when…

ok, edit, solved it by changing DNS backend to dnsmasq

That option creates firewall rules to redirect all requests to external DNS server to the local port 53.
Those rules are independent of the resolver, they should work with DNSmasq or Kresd.

Ekvivalent in

and on my router

What’s your problem actually? If you’re using DoH than you bypass the local DNS/adblock instance and the firewall redirect posted above as well.

This port forward setting (53,853, 5353) was created by me a long time ago when I installed AdBlock. Whether or not these rules are enabled has no observable effect on AdBlock behavior.

However, sometimes an ad passes from an address that is demonstrably disabled in AdBlock ! Reload Adblock /etc/init.d/adblock reload corrects the state.

I observed, if I enabled a higher value (then default 4) of Max. Download Queue in the AdBlock settings, bring perhaps an improvement.

Opera browser (from a certain time) on some web pages requested activation of DNS-over-HTTPS option.

I have currently disabled DNS-over-HTTPS in Opera and activated DNS forward to CZ servers in Foris. Now I’ll watch exactly how AdBlock works with this different settings .

Blocklist Sources in Turris AdBlock citation ??

Available blocklist sources. List URLs and Shallalist category selections are configurable in the ‘Advanced’ section. Caution: To prevent OOM exceptions on low memory devices with less than 64 MB free RAM, please do not select more than five blocklist sources!

I doubt that, this list works just fine for me, e.g.:

::: adblock runtime information
  + adblock_status  : enabled
  + adblock_version : 4.0.7
  + blocked_domains : 43703
  + active_sources  : adaway adguard disconnect yoyo 
  + dns_backend     : kresd, /etc/kresd
  + run_utils       : /bin/uclient-fetch, /bin/awk
  + run_ifaces      : trigger: wan, report: -
  + run_directories : base: /tmp, backup: /tmp, report: /tmp, jail: /tmp
  + run_flags       : backup: 1, reset: 0, flush: 0, force: 0, search: 0, report: 0, mail: 0, jail: 0
  + last_run        : start, 0m 12s, 2067/1879/1826, 03.02.2021 18:19:08
  + system          : Turris Omnia, TurrisOS 5.2.0 a7a207e18bf7fa04f265bb95cbe6fa91561fbfe8

I would guess you run in an out of memory condition …

hmmm, ok, let me reduce some list then, since this is my current one ?