Access point does not get internet connection


I have a Turris Omnia with OS version 5.4.4. Since the wifi does not reach all corners, I bought a TP-LINK RE605X WLAN Repeater to use it as an access-point. For this, I switched the tp-link to access-point mode and connected it via RJ45 to the turris omnia.

My devices can connect to the access-points WIFI, the access-point also shows up in turris, with an IP and a lease, but it cannot connect to the internet. I tried giving it a static lease, but that did not change anything.

I am not sure, what the issue could be, I can connect other devices just fine to the turris via RJ45. I would be glad, if someone could point me in the right direction for futher debugging :slight_smile:


p.s. I checked the cables, just in case.

Does the AP “know” what its IP address is?

If the AP is trying to use the wrong network ID and subnet, that could create the issue (where clients can still connect, but no internet access). Try logging in to the web console of the AP and see if there are any settings related to the network ID and subnet it is using.

And dont forget to turn off dhcp on that tp-link.


this screenshot show the config on the AP. It has an IP, over which it is reachable. I have disabled DHCP as well.
I also tried entering values (seen here greyed out), they have no effect. is my turris.

What confuses me is that the device is reachable from my other devices and also shows up on my turris (see table below, RE605X is the device name). It’s just not getting a connection to the internet.

Hostname  IPv4-Address MAC-Address Leasetime remaining

RE605X 30:DE:4B:CE:C8:27 11h 42m 56s

I have no special settings in my turris, pretty much the default setup (as far as I remember :slight_smile: )

You can try to set Turris DNS as the master DNS server in the network. That setting can be found in LuCI, somewhere in network settings, but I cannot remember where exactly.

Of course, you have tried to restart all your devices including, and TP-Link is connected in some of LAN ports (not WAN! right?

And why your Turris is not updated to the latest TOS version?

Okay, setting the turris explicitly as main DNS and then setting it in the TP-Link manually has worked. Thanks for the support.

As for the version, the UI tells me I am on the latest version :man_shrugging:

Though it does complain in the updater:

Updater failed: 

inconsistent: Requested package foris-netmetr-plugin that is not available.

I have removed tis package via LUCI, so I am not sure why this is still popping up.

Your are welcome. :slight_smile: Sometimes, when there are more DNS on the network, they are in conflict. I have found that, when my neightbour bought powerline TP-Link adapter, which was causing some problems (I am sharing internet connection with him).

Latest version is 6.3.3…

Netmetr package is deprecated and will be removed automatically in some of upcoming updates (if it wasnt removed already). This error, related to netmetr, is fully ok.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.