500 Internal Server Error

Hi

I am getting a 500 error luci works.

any idea.

Did you look through the 35 threads that the forum search turns up on the subject?

Annotation%202020-01-25%20094028

Notwithstanding, the initial post being short of basic information:

  • hardware platform, e.g. Mox, Turris, Turris Omina
  • TOS version
1 Like

I can not find an answer for this issue. I need access to this gui apparently to fix the borken local dns
Can you help please.

Please provide useful information, especially Logs!

See here for how to get them: Support - Turris Documentation

If you want an instant solution and you don‘t have a too much customized configuration you can just do a factory reset. You will need to start from scratch then. See here:
Omnia: Redirecting...
Mox: Redirecting...

I‘d recommend a 4 LED Factory reset foe Omnia or Rescue Mode 6 or 4 for MOX so that you start from latest stable firmware…

Last but not least you should definitly read answears of people who try to help you…

1 Like

Hello,

I just installed the latest stable version of Turris OS: 5.1.4 (4 LED Factory reset) to my Turris Omnia (I used the latest 3.x version before) - As far as I know this was clean installation as I need to setup everything…

I additionally installed yamon and luci-app-access-control_0.4.3_all.ipk and continue with configuration (e.g. I changed my router ip to 192.168.10.1)

Then I run pkgupdate and it required reboot. After reboot luci stop to work with: “500 Internal Server Error”. I uninstalled luci-app-access + other not needed apps, rebooted rooter, but it did not help.

I tried to check logs at /var/logs, but I did not find there anything about luci. Foris, Reforis, and Yamon works.
How to make luci working again? Where I have to check for reason of “internal server error”?

I “solved” this by remove all luci packages with:
opkg list-installed | grep luci | cut -f 1 -d ' ' | xargs opkg remove --force-removal-of-dependent-packages
and then running pkgupdate that reinstalled all necessary packages once gain. Now luci is working.