5 GHz Radio Keeps Failing


#1

This appears to be a problem with the hardware in the router. I’ve read other topics on the subject but there doesn’t appear to be a resolution and most of them are relatively old.

Simply put, the networks I set up on the “Qualcomm Atheros QCA9880 802.11bgnac (radio0)” radio do not activate. I’ve tried a variety of configuration adjustments (changing the country, channels, etc) as other posts have worked through. Nothing seems to permanently enable this radio.

I’m just wondering if this chip is flawed, which would essentially render the router useless, or if a fix has been recognized and documented?

Any help is appreciated.


#2

You can try putting the card into different slot to debug it.


#3

I have the same issue. After trying all SW tweaks in forums worldwide without success I tried swapping slots but no success too. Initially the card didn’t show up at all but later it came in state that every second boot it shows up. I assume it has something to do with card temperature or residual voltage because the card is detected every second reboot or when the router is switched off for few minutes. So it seems that card is only working in cold boot state.
On some forum was reported that the problem was solved simly just by exchanging the card only by CZ.NIC. I opened the ticket and they requested me to send the router but I didn’t so far.
As temporary workaround I made a script checking if card is not detected and reboot. There is no boot loop due to this because the card is detected every cold boot / second boot.
Opposite to my assumption see https://wikidevi.com/wiki/Compex_WLE900VX where is stated:

Known Issues
This card is reported to have some incompatibilities with many notebook BIOSes.
While on some motherboards the card works fine, on some motherboards it only shows in
the PCI device list only after a warm boot, and on some others platform it will never work[1]
Compex did not find a solution yet[2]

So they say warm boot but in my case it seems to work in cold boot only.

I think that CZ.NIC knows very well about this issue and root-cause as this problem was discussed very often on forums and I believe many users claimed this. I also noticed somewhere that solution can be to put card in the most left slot and/or exchange some capacitors on board I think.


Wlan 5g not starting most of the time