YAMon v4.0.4 now includes access restrictions

OK… I’ve just pushed v4.0.4 into the wild (https://usage-monitoring.com/installv4.php). In addition to a number of bug fixes, this release finally includes a way to define rules which will prevent certain devices from accessing the web - i.e., you can say that your children’s devices cannot access the web between 10PM and 7AM on school nights and 11:30PM and 9AM on weekends, etc.

See https://usage-monitoring.com/current/SetAccessRestrictions.php for a working example of how to manage the restrictions.

NB - to use this feature on your router, you will have to upgrade to v4.0.4 and enable the database integration options (which is a new prompt in the setup script)

I’m really keen to hear feedback on this new feature. I’ve been running it on my router for a while now and everything seems to work well.
One caveat however, be careful how you define your rules as you could accidentally block all devices on your network.

As always, your feedback is appreciated!


1 Like

I had some trouble setting 4.0.4 up on my 3.11.10 Omnia.

Previous/currently I have YAMon 3.4.7 running.

When I run setup.sh, It complains that alias.sh, block.sh, changes.log and getACRules.sh are missing. So, I downloaded them from your site and ran ./install.sh again.

The second time, it got snagged on importing the v3 config.file

   Copying settings from '/opt/YAMon3/config.file' to '/opt/YAMon4/config.file'

/opt/YAMon4/setPaths.sh: /opt/YAMon4/config.file: line 47: syntax error: unexpected "("
./install.sh: /opt/YAMon4/config.file: line 47: syntax error: unexpected "("

Line 47:

_dailyBUPath='/mnt/sda1/opt/YAMon3/daily-bu/'# path to back-ups directory (* if null, defaults todaily bu/)

I added a space in front of the # and it finished when I ran it again.

However, when I run ./start.sh in the /opt/YAMon4 directory, it never returns to a prompt. If I put it in the background and I go to the main web page, there’s a red X in front of ‘Settings from database …’ and complains ‘Database name is null’. There’s also a ? next to ‘Settings from localStorage’

I poked at the config.file, but didn’t see anything obvious. I can post that if it’s helpful.

Thanks for your input. I’ll have to look into your _dailyBUPath issue.

This is what I see when I run start.sh (NB - I am running it from the aliases so sta is my abbreviation for /opt/YAMon4/start.sh
Currently, other than the splash screen, there is no message that explicitly states that YAMon started properly … I should probably fix that too.

Last but not least, try reloading the reports (perhaps with a ctrl+F5 to flush the cache)… In my haste to get the router scripts updated on the server, I forgot to also update the JS files. You should not get the database name is null message anymore.

FYI, I have a parallel test environment which loads the files from /dev rather than /current. You can use this in the reports by choosing that option the Debug section on the Settings tab:

That’s what I get too, except it never returns to a prompt. Perhaps I’m not waiting long enough, though I’ve waited several minutes a few times.

I’ll also have to remember to stop v3 since it seems have v3 and v4 running causes iptables to bring the router to it’s knees.

It does not work :(.

Lukáš - thanks for your input. Sorry you’re having troubles (it is just the first iteration of this new feature so testing and debugging will be necessary)

Can you tell me what when wrong? Screen shots, log files, etc.

Thanks for your help. Happy holidays!