Yamaha receiver problem with Knot DNS


#21

My problem is solved. The main problem is compression. I’ll be cooperate with CZ.NIC on standard solution for everyone.

Btw Google is down. End of the world is comming :slight_smile:


#22

Just to confirm that the most possible culprit is the DNS compression that behaves differently from what BIND is doing, and perhaps those devices expect the DNS packet to look exactly like this instead of following the DNS specification.

Unfortunately it looks like that even disabling DNS compression altogether doesn’t help some of the devices (Garmin namely), so even though Knot Resolver does follow existing standards, we will now implement the exactly same DNS compression algorithm to ensure compatibility with those horrible devices.

This needs to be fixed in libknot and therefore it will takes us some time to fix it properly, so please be patient (and use non-Omnia resolver for those devices).


Garmin products unable to use Wifi despite IP address attributed
#23

Thanks @oerdnj for insight. For everybody experiencing issues with crappy devices, you should be able to assign different DNS resolvers via DHCP just to specific devices like this:

# cat /etc/config/dhcp
…
config host
        option name 'garminwhatever'
        option mac '00:12:34:56:78:9a'
        option ip '192.168.1.200'
        option tag 'googledns'

config tag googledns
        list dhcp_option '6,8.8.8.8'

IPv6 to only some clients
Radio Streaming Problem - DNS?
Garmin products unable to use Wifi despite IP address attributed
Garmin products unable to use Wifi despite IP address attributed
Android Issue post 3.8
Správné nastavení DNS a nepřipojení některých zařízení
#24

Unfortunately, I’ve just RMA’ed my crappy device back to Garmin!.. so I’m unable to test this at the moment.


#25

This solution works with my Garmin Index “Smart” scale.


#26

Does your scale go through the ‘spanner’ to a successful completion? I was able to get mine to successfully get the DNS and start the conversation with gold.garmin.com, but it never successfully completed?


#27

Yep, it does (with that “progress bar” ended with check-mark) and I can see on Garmin Connect the result too.
Before Ondrej’s workaround I had indication that WiFi connection was established but data was never successfully sent to Garmin (thus never showing the “progress bar”).


#28

Ack! too late for me then, the scale went with the courier yesterday back to Garmin. Will await the replacement with hope it will be working all OK then! :slight_smile:


#29

Can confirm this worked on my garmin index scale aswell.


#30

So after a load of work getting my router up to the 3.6.1 OS, I had to implement the tagged DNS solution above and can confirm it worked for my Garmin and router now running KRESD


Yes, I am leaving
#31

I can confirm that this solution worked for my LG washing machine (aka one of the crappy devices). I had used this approach before giving up on Knot and going back to dnsmasq-full.


Turris 1.x wi-fi upgrade balíček
#32

I can add Rachio sprinkler controllers to the list of devices that hit this issue. The workaround (supplying an alternate public DNS to the problem device) did work.

It appears that one year on we don’t have a fix for this yet, is there anywhere to track the progress on it?


#33

It should be worked around by updating to libknot >= 2.6.0. It was released upstream, but the update isn’t yet available for Omnia, not even -nightly. /cc @paja.


#34

I test this issue about once of month. Last test was two weeks ago and the issue has not be resolved.


#35

I will notify this thread when newer libknot gets to Omnia. Until then the issue seems unlikely to change.


A Kresd Journey
#36

#37

It’s good news! Maybe I try RC 3.9, but it depends to my free time.


#38

It’s scheduled for stable (i.e. everyone) during the next week.


#39

I tested RC 3.9 and Y receiver works! Thanks to developer team.