WLAN0 down (ath10k)

Hi, just noticed that my Qualcomm Atheros QCA9880 802.11acbgn adapter (ath10k) is not coming up. Started either today or yesterday. I’m on HBL. Details below. Not really sure what’s happening. Tried the usual stuff - restart network, reboot, etc. I can’t return to HBK for example, pkgupdate complains about missing https://repo.turris.cz/hbk/omnia/lists/drivers directory (which is true, it seems to haven appeared in HBL). Any ideas?

logread -e wlan0:

Feb 10 21:05:40 orbis kernel: [ 24.605868] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Feb 10 21:05:40 orbis kernel: [ 24.640099] br-lan: port 7(wlan0) entered blocking state
Feb 10 21:05:40 orbis kernel: [ 24.645468] br-lan: port 7(wlan0) entered disabled state
Feb 10 21:05:40 orbis kernel: [ 24.650987] device wlan0 entered promiscuous mode
Feb 10 21:05:55 orbis kernel: [ 42.534151] device wlan0 left promiscuous mode
Feb 10 21:05:55 orbis kernel: [ 42.538701] br-lan: port 7(wlan0) entered disabled state
Feb 10 20:06:00 orbis hostapd: wlan0: interface state DFS->DISABLED
Feb 10 20:06:00 orbis hostapd: wlan0: AP-DISABLED
Feb 10 20:06:00 orbis hostapd: wlan0: CTRL-EVENT-TERMINATING
Feb 10 20:06:00 orbis hostapd: hostapd_free_hapd_data: Interface wlan0 wasn’t started
Feb 10 20:06:00 orbis hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Feb 10 20:06:00 orbis hostapd: nl80211: Failed to remove interface wlan0 from bridge br-lan: No such device
Feb 10 21:06:06 orbis kernel: [ 53.338702] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Feb 10 21:06:06 orbis kernel: [ 53.377881] br-lan: port 7(wlan0) entered blocking state
Feb 10 21:06:06 orbis kernel: [ 53.383246] br-lan: port 7(wlan0) entered disabled state
Feb 10 21:06:06 orbis kernel: [ 53.388723] device wlan0 entered promiscuous mode
Feb 10 20:06:06 orbis hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Feb 10 20:06:06 orbis hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Feb 10 20:06:07 orbis hostapd: wlan0: interface state HT_SCAN->DFS
Feb 10 20:06:07 orbis hostapd: wlan0: DFS-CAC-START freq=5260 chan=52 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
Feb 10 20:07:04 orbis hostapd: wlan0: DFS-CAC-COMPLETED success=0 freq=5260 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5290 cf2=0
Feb 10 20:07:04 orbis hostapd: wlan0: INTERFACE-DISABLED
Feb 10 21:07:04 orbis kernel: [ 110.041841] br-lan: port 7(wlan0) entered disabled state
Feb 10 21:07:05 orbis kernel: [ 110.091356] device wlan0 left promiscuous mode
Feb 10 21:07:05 orbis kernel: [ 110.095818] br-lan: port 7(wlan0) entered disabled state
Feb 10 20:07:06 orbis hostapd: wlan0: INTERFACE-ENABLED
Feb 10 20:07:06 orbis hostapd: wlan0: interface state DFS->DFS
Feb 10 20:07:06 orbis hostapd: wlan0: DFS-CAC-START freq=5260 chan=52 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
Feb 10 21:07:06 orbis kernel: [ 111.757673] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Feb 10 20:07:06 orbis hostapd: wlan0: INTERFACE-DISABLED
Feb 10 20:07:06 orbis hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Feb 10 20:07:06 orbis hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Feb 10 20:07:06 orbis hostapd: wlan0: AP-DISABLED
Feb 10 20:07:06 orbis hostapd: wlan0: CTRL-EVENT-TERMINATING
Feb 10 20:07:06 orbis hostapd: hostapd_free_hapd_data: Interface wlan0 wasn’t started

iw reg get:

root@orbis:~# iw reg get
global
country CZ: DFS-ETSI
(2400 - 2483 @ 40), (N/A, 20), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
(5725 - 5875 @ 80), (N/A, 13), (N/A)
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country US: DFS-FCC
(2400 - 2472 @ 40), (N/A, 30), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5730 - 5850 @ 80), (N/A, 30), (N/A)
(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
(2400 - 2472 @ 40), (N/A, 30), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5730 - 5850 @ 80), (N/A, 30), (N/A)
(57240 - 71000 @ 2160), (N/A, 40), (N/A)

ifconfig:

root@orbis:~# ifconfig
br-guest_turris Link encap:Ethernet HWaddr 6A:E8:95:CB:C0:79
inet addr:10.111.222.1 Bcast:10.111.222.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

br-lan Link encap:Ethernet HWaddr 04:F0:21:45:C1:69
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::da58:d7ff:fe01:353b/64 Scope:Link
inet6 addr: fd11:5ab8:f9d8::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:22703 errors:0 dropped:0 overruns:0 frame:0
TX packets:24563 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3225279 (3.0 MiB) TX bytes:23972119 (22.8 MiB)

eth0 Link encap:Ethernet HWaddr D8:58:D7:01:35:3D
inet6 addr: fe80::da58:d7ff:fe01:353d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:0 (0.0 B) TX bytes:1782 (1.7 KiB)
Interrupt:37

eth1 Link encap:Ethernet HWaddr D8:58:D7:01:35:3B
inet6 addr: fe80::da58:d7ff:fe01:353b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17930 errors:0 dropped:0 overruns:0 frame:0
TX packets:32812 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:3107292 (2.9 MiB) TX bytes:22049914 (21.0 MiB)
Interrupt:38

eth2 Link encap:Ethernet HWaddr D8:58:D7:01:35:3C
inet addr:192.168.88.1 Bcast:192.168.88.255 Mask:255.255.255.0
inet6 addr: fe80::da58:d7ff:fe01:353c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:40075 errors:0 dropped:0 overruns:0 frame:0
TX packets:26946 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:42694144 (40.7 MiB) TX bytes:3467668 (3.3 MiB)
Interrupt:39

ifb4br-guest_tu Link encap:Ethernet HWaddr 7E:B4:2F:CA:0E:37
inet6 addr: fe80::7cb4:2fff:feca:e37/64 Scope:Link
UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:32
RX bytes:909 (909.0 B) TX bytes:909 (909.0 B)

lan0 Link encap:Ethernet HWaddr D8:58:D7:01:35:3B
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14778 errors:0 dropped:0 overruns:0 frame:0
TX packets:21429 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2141870 (2.0 MiB) TX bytes:19967978 (19.0 MiB)

lan1 Link encap:Ethernet HWaddr D8:58:D7:01:35:3B
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1880 errors:0 dropped:0 overruns:0 frame:0
TX packets:5087 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:189125 (184.6 KiB) TX bytes:773089 (754.9 KiB)

lan2 Link encap:Ethernet HWaddr D8:58:D7:01:35:3B
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:275 errors:0 dropped:0 overruns:0 frame:0
TX packets:3710 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:53987 (52.7 KiB) TX bytes:720182 (703.3 KiB)

lan3 Link encap:Ethernet HWaddr D8:58:D7:01:35:3B
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:984 errors:0 dropped:0 overruns:0 frame:0
TX packets:2571 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:326422 (318.7 KiB) TX bytes:324507 (316.9 KiB)

lan4 Link encap:Ethernet HWaddr D8:58:D7:01:35:3D
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:22235 errors:0 dropped:0 overruns:0 frame:0
TX packets:22235 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9394075 (8.9 MiB) TX bytes:9394075 (8.9 MiB)

tun_turris Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:10.111.111.1 P-t-P:10.111.111.2 Mask:255.255.255.255
inet6 addr: fe80::3517:51af:3d91:2fc8/64 Scope:Link
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:304 (304.0 B)

wlan1 Link encap:Ethernet HWaddr 04:F0:21:45:C1:69
inet6 addr: fe80::6f0:21ff:fe45:c169/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4802 errors:0 dropped:0 overruns:0 frame:0
TX packets:8341 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:672714 (656.9 KiB) TX bytes:5564071 (5.3 MiB)

wlan1.sta3 Link encap:Ethernet HWaddr 04:F0:21:45:C1:69
inet6 addr: fe80::6f0:21ff:fe45:c169/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:853 errors:0 dropped:0 overruns:0 frame:0
TX packets:2330 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:65613 (64.0 KiB) TX bytes:638182 (623.2 KiB)

cat /etc/config/wireless:

root@orbis:~# cat /etc/config/wireless

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ‘11a’
option macaddr ‘04:f0:21:45:da:2d’
option country ‘CZ’
option channel ‘52’
option htmode ‘VHT80’

config wifi-iface ‘default_radio0’
option device ‘radio0’
option network ‘lan’
option mode ‘ap’
option ssid ‘Orbis’
option encryption ‘psk2+ccmp’
option wpa_group_rekey ‘86400’
option wds ‘1’
option disabled ‘0’
option hidden ‘0’
option key ‘oh-my-private-parts (not my real PW :-p )’

config wifi-device ‘radio1’
option type ‘mac80211’
option hwmode ‘11g’
option macaddr ‘04:f0:21:45:c1:69’
option country ‘CZ’
option disabled ‘0’
option htmode ‘HT40’
option channel ‘1’

config wifi-iface ‘default_radio1’
option device ‘radio1’
option network ‘lan’
option mode ‘ap’
option disabled ‘0’
option ssid ‘Orbis’
option encryption ‘psk2+ccmp’
option wpa_group_rekey ‘86400’
option wds ‘1’
option key ‘oh-my-private-parts (not my real PW :-p )’

config wifi-iface ‘guest_iface_0’
option device ‘radio0’
option mode ‘ap’
option ssid ‘OrbisG’
option network ‘guest_turris’
option encryption ‘psk2+ccmp’
option wpa_group_rekey ‘86400’
option key ‘oh-my-private-parts (not my real PW :-p )’
option ifname ‘guest_turris_0’
option isolate ‘1’

config wifi-iface ‘guest_iface_1’
option device ‘radio1’
option mode ‘ap’
option ssid ‘OrbisG’
option network ‘guest_turris’
option encryption ‘psk2+ccmp’
option wpa_group_rekey ‘86400’
option key ‘oh-my-private-parts (not my real PW :-p )’
option ifname ‘guest_turris_1’
option isolate ‘1’
option disabled ‘1’

Also, strangely the ac and bgn adapters seems to have swapped places, radio0 used to be bgn and radio1 used to be ac. Now they’re swapped. Dunno when that happened.

This is interesting:

/var/log/messages extract:

Feb 10 21:05:40 orbis kernel: [ 13.501845] pci 0000:00:02.0: enabling device (0140 -> 0142)
Feb 10 21:05:40 orbis kernel: [ 13.507543] ath10k_pci 0000:02:00.0: enabling device (0140 -> 0142)
Feb 10 21:05:40 orbis kernel: [ 13.514076] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
Feb 10 21:05:40 orbis kernel: [ 13.754000] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
Feb 10 21:05:40 orbis kernel: [ 13.764749] ath10k_pci 0000:02:00.0: Falling back to user helper
Feb 10 21:05:40 orbis kernel: [ 16.131289] firmware ath10k!pre-cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
Feb 10 21:05:40 orbis kernel: [ 16.140454] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
Feb 10 21:05:40 orbis kernel: [ 16.150857] ath10k_pci 0000:02:00.0: Falling back to user helper
Feb 10 21:05:40 orbis kernel: [ 16.161518] firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
Feb 10 21:05:40 orbis kernel: [ 16.170312] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
Feb 10 21:05:40 orbis kernel: [ 16.181062] ath10k_pci 0000:02:00.0: Falling back to user helper
Feb 10 21:05:40 orbis kernel: [ 16.191850] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
Feb 10 21:05:40 orbis kernel: [ 16.209343] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
Feb 10 21:05:40 orbis kernel: [ 16.218626] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
Feb 10 21:05:40 orbis kernel: [ 16.228154] ath10k_pci 0000:02:00.0: firmware ver 10.2.4-1.0-00047 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 35bd9258
Feb 10 21:05:40 orbis kernel: [ 16.272951] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
Feb 10 21:05:40 orbis kernel: [ 16.283422] ath10k_pci 0000:02:00.0: Falling back to user helper
Feb 10 21:05:40 orbis kernel: [ 16.294260] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
Feb 10 21:05:40 orbis kernel: [ 16.304323] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Feb 10 21:05:40 orbis kernel: [ 17.444436] ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1

Whoa… it just randomly came up. How odd… No idea what’s going on with it. I think I’ll just not touch it now :slight_smile:

One idea (if you have an Turris Omnia): unplug power cable and let the Wi-Fi-card cool down (~2-5 min). Then replug power cable.
It’s a known hardware bug of the first (Indiegogo) batch of Turris Omnias.

If it is a later revision of Turris Omnia or a MOX it might also be a too hot Wi-Fi-card (but that’s just a suggestion).

You may circumvent this in an Ombia by installing a heatsink.

Hey dude, it’s quite a new omnia, maybe 2 months old. Anyway when (if) is happens again, I’ll try your suggestion. Thanks!

Can the Hardware bug in the first Indiegogo batch be solved? Or do i need to install a new wifi card?

Yes, it can.
Depending on your warranty status you can send it for repair to Turris support. Please search on this forum, this has been answered by @Pepe if I remember correctly. Reach out to their support to clarify the details, because before sending it there are some checks to be made to verify it is really that distinct bug and nothing else.
I myself (/my family) cannot live for weeks (located in Germany the shipping will take at least 1 week one way if I remember correctly) without the Turris WiFi therefore I decided to live with the bug. But in my case it never failed when the router was running, but only when I wanted to restart it.

OK, then this would not be root cause in your scenario.

Solution can be found here: Switch to lower branch - SW help - Turris forum

Why do you find it interesting? You can find this output on the OpenWrt forum and here. This is harmless even though it can be confusing. It just tries to load some FW until it finds the correct one.

Were you changing your position of Wi-FI cards? How did you configure your Wi-Fi via re/Foris or LuCI? You should check if your mac address of each radio corresponds to Wi-Fi cards’s MAC addresses in your case.

I’d rather say that this is bug of Compex WLE900VX Wi-Fi card as each behaves differently. While looking to issues which we experienced on Turris MOX and our kernel developers fixed it. But detailed explanation is here on forum, so interested users can find it. :slight_smile:

1 Like

Well, I thought it may be relevant, but it was a “red herring”. Afterwards I read that it’s normal behaviour as the kernel tries to load various drivers until it finds one that works.

Nope, didn’t touch it. Completely random. MAC address seem ok. Config done mainly via LuCI.

Anyway, it seems to be ok now, so I’ll just put it down to voodoo magic.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.